Problem with Multi Channel Control SmartApp

With the new update I’m having trouble with the Multi-Channel Contro SmartApp. When I add a multi channel device and try to add the Smart App… I press “install” and nothing happens. Before the update that worked fine.
If I try to install the SmartApp and associate it with the device it never “creates” the new devices.
Any Idea?


1 Like

I’m having the same issue. I see you never received a response but I was hoping you figured something out. I had been using another smartapp but the multi-channel control app seemed to work better.

Please let me know if anyone has any insight.

I am having this same issue now. I installed one ZWN-RSM2 and it paired as a Z-Wave Device Multichannel device and I was able to use the Multi-Channel Control SmartApp to set/control the 2 end points. This was in Jan/Feb.

However when I just installed another one, and tried to install the Multi-Channel Control SmartApp I got the same thing. I was able to select the relay and name it, but after installing it I was not able to select each endpoint and configure the switch.

I hate this because those two working together (and executing locally on the hub) work flawlessly. I ended up using a community device driver for the relay, creating two virtual switches and then using the community created SmartApp to assign those two virtual switches to the end points. Not exactly what I wanted to do, since my other relay is working just fine with the native handlers and apps.

I wonder if @slagle knows anything about this - since it is an approved SmartApp that runs locally…


Any update on this?

It still does not create the new device when you install the Multi-Channel Control SmartApp from the Marketplace. Is this app dead and no longer supported? Just looking for any kind of answer please.


I’m having the same issue with Enerwave ZWN-RSM2

Hi, I added a device yesterday (Chinese device) without problems, but it happened to me a days ago.
What I’m experiencing are random delays to update the state of the virtual tiles and in same cases the state at the “Things” screen doesn’t match with the state showed when you click to see the device values.

Sorry to ask you about such an old topic but did you ever figure out the delay on seeing state changes IV multichannel devices?

Hi, were you able to solve this issue? As I am having the same issue as well.

I am having this issue. Anyone know how to fix