Much trouble after migrating from Classic, help needed

Hi folks,

I have several problems with the new SmartThings app after being forced to migrate earlier this month that I’ve been trying to work through without success.

Background: I’m a long-time user (since late 2014, and I have a v1 and a v2 hub) with literally hundreds of devices. I haven’t counted them, but I’m guessing I have about 150-200 on my v1 hub and another ~50 on my v2 hub. They are a mix of Z-Wave, zigbee, and LAN/cloud integrations.

Here are some of the problems I need help with.

  1. Resolved. Thanks @jkp! I cannot locate the z-wave utilities in the new app. I’m trying a general exclusion, and I can’t find that option. The instructions here do not work for me because the “Z-Wave Utilities” option does not appear under the “More Options (:)” menu when viewing Devices. Here is what I see, instead:

  2. I cannot add new Z-wave devices. I’m trying to pair two new switches (Zooz and Inovelli), and both continually timeout. The hub is 4 feet from the switches. (I measured it!)

  3. Many (but not all) of my automations from the Classic app now fail after the migration. Geofenced automations do not run (even after I figured out how to change my iPhone presence sensor device), time-based automations do not run or do so intermittently (I guess not a big surprise - this was always a problem in Classic, too), and automations that I trigger manually (using a Scene in the new app) report failure for an “unknown device”.

  4. I tried to figure out why scenes fail, but live-logging in the IDE doesn’t work anymore. Instead, it refers you to the History function in the new app (less than ideal, but okay, I can work with that). However, the History log in the new app pops to the top every time a new message appears. With several hundred devices, this occurs constantly and does not allow me to review past events.

  5. Status updates in the new app are abysmally slow. Side-by-side compared to the Classic app, the new app takes 30+ seconds to download device status, but Classic is < 1 second. Similarly, activating a device via the new app is also abysmally slow taking so long that the app itself reports a network error. However, the same action in Classic occurs in < 1 second. Performance is orders of magnitude better in the Classic app compared to the new app.

  6. A handful of my devices do not have updated device types that work with the new app, and some of the apps are wonky. i.e. Button Controller doesn’t work right anymore, and Hank 4-button scene controller and aeon 4-button minimote buttons are not visible to the new scenes engine. Fortunately, they still work with CoRE. My aeon smartstrip needs extra help to work through the new app as the old DTH doesn’t work anymore. I used a community DTH for my z-wave fan controllers, but the new built-in UI for the new app still uses the dimmer metaphor (a poor analogy) and doesn’t use the custom DTH’s UI. I haven’t checked in detail, but I’m guessing most or all of the customer DTHs I used are no longer working in the new app. This is more a complaint than a request for help - I’m aware of the changes to the UI in the new app that make older DTHs not work, but it’s annoying to have to unwind hours of configuration effort nonetheless.

HELP! If anyone has any tips or can offer any help on the above issues, I’d appreciate it.

-Andrew

1 Like

The z-wave utilities do not show in the new app for the v1 hub. You will need to login to IDE > hubs > view utilities and use z-wave utilities from there.

Thanks!

If that was communicated to users, I clearly missed it.

Reboot your hub, go to z-wave utilities in IDE and exclude, then try to add in new app > +(plus) in the upper right of the scree, choose the by brand section, and scan nearby at the bottom of the screen or choose z-wave

You may want to post screenshots. Many users are having similar issues and may be able to offer assistance if they see your automations.

Ok… 3 down … getting through the list.

Yes, this one you have figured out. It has been more difficult. You might get some log details in ide > hubs > view events

Unfortunately, I’m still having trouble here. I think I was able to do a general device exclusion and start inclusion again, but the app reports that the device isn’t responding.

Interestingly, the events log for the hub in the IDE does seems to show a new device being added.

(Don’t be thrown by the timestamps - I sat on the iOS screen for a few minutes before doing the screencap.)

Thoughts?

Ugh. :confounded: A lot of good that does. I’ll keep my fingers cross that Samsung figures out a better way for this.

Did you restart hub? Bring it as close as possible to the hub? Did you try both scan nearby and the z-wave option? Do you think it excluded properly?

Wait…I forgot! The usual for me.your custom device handlers you have in IDE, open them and publish for me. There is a known issue where they can become stale preventing you from pairing devices. Then exclude and try to pair. But publish for me in all your custom device handlers in IDE.

I did restart the hub, yes. I’ve restarted a few times, actually, but that one event log screencap didn’t capture the reboot.

I did the scan nearby and the by brand inclusion. No love. :frowning:

This is still a bug?! I published for me, but it made no difference.

you can try the classic app to see if you can install your devices. also report the issue to ST support to let them investigate

I’m having the same issues as you. Trying to add new devices in the new app and they’re not being detected. Devices are within 6 feet of hub.

1 Like

I think they have (and have had) a real bug here for a long time. What happens if you open classic and ‘add a new device’ do the devices you tried ti add just magically show up?

Not for me. I can’t add any devices in the classic app either. I’m stuck with manual control of 3 newly installed z wave switches.

FYI. I updated my iPhone to iOS 14.1 from iOS 14.0.1 and it fixed my issue.