Most devices showing as offline but only in new App

Hi all,

A couple of days ago I changed the password on my samsung account. I did this through the web browser on my pc when I was logging into the Groovy IDE. I reopen the app on my phone, signing back in with my new password. I notice that most of my devices show as offline, Lifx, harmony, simulated switches, virtual switches, tplink plugs all offline in the new app. The only devices that show as online are zigbee and zwave devices connected directly to the hub.

All my automations were still running correctly. They are all showing up online in the old ‘classic’ app or through Groovy IDE it’s only the new app that is showing incorrectly. I’ve tried re-installing both apps, I’ve reset my router and the hub…

I’m a bit lost as to what to do next other than remove all those devices and set them up again which seems pretty pointless when everything is still being automated.

@tech2urdoor, I have seen a similar post yesterday, exactly what you described, generally, except the password change. Let me find it and will post it here.
The person actually was mentioning LIFX, so I guess it is some C2C backend issue.

Here we go, the title was almost the same:

@Brad_ST, is there any know issue today with the C2C devices?

It definitely sounds like a similar problem. I think the password change was just a coincidence. My partners phone app shows the same devices as offline and she hasn’t made any changes.

Check the status in the IDE. I very occasionally see things OFFLINE in the apps and HUB_DISCONNECTED in the IDE. If that’s the case, a reboot of the hub should clear it up.

The, hopefully related, issue I’ve had for the last three days is that a number of devices show the ‘wrong’ status in the ‘new’ app tiles. They sometimes show ‘Offline’ but more often they either show ‘Getting status …’ indefinitely, or they just have a blank status (it depends on what I’ve been doing to try and restore sanity most recently). The device pages display fine but if they offer automation shortcuts those fail with an error toast, and in the Automations, when you try and add a device status condition, none of the problem devices are shown. Everywhere else these devices work perfectly. Indeed they even show an accurate and timely offline message on the device page if genuinely offline.

At the same time, some devices display and work just fine in the new app. Unfortunately it took me a long while to recognise the pattern because I’ve been messing around with device profiles that possibly aren’t supposed to work anyway. However the pattern I’ve finally recognised is that the devices that aren’t giving problems in the app are the ones that are trying to display the default status, which is whether the device is online or offline (or however it is dressed up e.g. connected). Those that have suitable metadata to make them display a different status in the tile e.g. switch, motion, presence, button, work just fine.

I don’t suppose you can relate to that pattern can you?

When I see this, going into the room and back out fixes it for all devices showing this, even if they are in other rooms. It’s like a total refresh happens.

1 Like

That’s my issue currently!! They are constantly “getting status” or whatever it is, and then if I tap a device, they flash “offline” and then online and then offline and online and so on forever.

It’s insanely annoying because I can’t tell if that’s what’s preventing me from working on my automations or if it’s something else. I’m dying for an app update that fixes it.

I used to have that but I haven’t noticed it so much lately. What I am talking about here not only doesn’t get fixed like that but survives phone reboots, hub reboots, app restarts, app cache clears, app force stops, app reinstalls, changing to developer mode, changing out of developer mode, device handler updates, device updates, device updates with changes, device profile pushes, device repairing, device removal and reinstallation, metadata changes, and so on. The only thing that fixes it is using whatever metadata is (or isn’t) required for the tile status to be based on something other than the connection health. Then it can get the status and it all works.

Up until late on Monday evening (UK time), I had tiles showing the device health whether I liked it or not. By early Tuesday morning it had stopped working.

I’m having this same problem. I’m using the new ST app, as my SmartThings account was migrated previously. The old app doesn’t work for me anymore.

Devices and hub say “offline” and are similarly unavailable via Alexa. But the light on my v2 hub is solid green, so all is well. Groovy IDE is showing devices as having been accessed within the last few seconds or minutes. SmartThings says all services are functioning normally. But my system is completely down.

Any ideas? I’ve rebooted the hub several times, no joy. I even changed the port on the hub as well as the cable before I realized it seems to be the app that’s the problem. Thank you!

There is a widespread system outage today, 4 August 2020, affecting multiple users. See the existing threads.

:frowning:

Guess I’ll need to wait a bit until I can control my Amazon smart plug using my Google Assistant…
(via a virtual switch, also, I don’t have a hub yet, if that matters)

Any updates on this issue. I have this same problem now that I decided to migrate everything to the new ST app. And the old app is useless.

Advice on a different thread from SmartThings staff was to power off your hub, leave it off for over 5 minutes, then restart.

If you have a V2 hub remember to pull the batteries.

1 Like

I tried this twice, and it did not help. Everything is online in the IDE and old app, but all Zigbee devices and my two Z-wave locks + hub are offline in the new app.

Next step is to call support

What is the phone number?

https://lmgtfy.com/?q=SmartThings+support

Since I changed my email account, my hubs and devices show as offline in the new ST app. I can still control devices in the classic app. I have rebooted and checked that the email in Groovy is the same as my login email. No luck the new app shows everything offline. Any suggestions?