Monoprice motion sensor help request


(George) #1

I am having problems with a new monoprice motion sensor, and wondered if anyone else has seen similar behavior and/or has ideas on how to fit it. I noted from other post several people have been using this device without problems…

The sensor does not seem to report motion events, although it is reporting temperature fine. When I first paired it, it was reported as an AEON Multisensor. I first tried changing the device type to a generic Z-Wave motion sensor, which seemed to work but did not fix the motion reporting issue. I then changed the device type to the custom device-type for this monoprice sensor created by @florianz, and the temp continued to be reported but still no motion.

Other things I"ve tried:

  • Pulling/re-inserting battery to reset the device
  • Excluding, then re-including the device
  • Rebooting the hub after changing device type

I’m wondering if I am missing something in the setup process, or the sensor itself is defective. The latter seems unlikely since I am getting temp readings. I also see the “tamper event” notification when I open the case.

I did get a single “no motion detected” event in the event log immediately after initial inclusion, but nothing after that. BTW, I am aware that there is a several minute delay between motion events reporting in its normal operation, but I’m not seeing any events when checked over long periods of time.

Thanks in advance for any suggestions


(Florian Z) #2

Totally sounds like you received a defective device. My guess is that the PIR sensor is broken or has defective solder joints. Try to get a replacement from Monoprice so we can rule out a defective unit. Before you send it back, open up the device and make sure that the PIR is not obstructed in any way.


(George) #3

An update to close the loop… I returned the sensor and ordered a couple of new ones, which arrived today. These work as expected, so the first one was indeed defective. thanks.


(Brady Emmett) #4

I am having similar problems with the Monoprice Motion sensors.

I purchased some a few months back, and just repurchased another to test out the advice I got from the Monoprice help desk. (They claimed that there was no way I had multiple defective units, so I got a new one that I could return if needed to test that claim.)

I can get them to successfully pair to my hub. I can update them to @florianz’s Motion Sensor device type. But the only thing that they are reporting back is the open/close alarm. No motion, no temperature. Nothing. Same issue on both the ones I bought several months ago, and the one I received today.

I’m at wits end trying to figure out what the next step in sussing this out is… Any ideas?


(Indy Quad) #5

@georgeh Are you seeing “motion” always in the “things”?i.e stuck at detecting the first motion. I pulled the battery and put the battery in “Recently” I see only one motion detected event.


(George) #6

not seeing that behavior.


(Gary Davis) #7

I am having the same issue. No motion detected after pairing with SmartThings. The manual says the LED lights steady after paring but mine goes out (from slow blink) after pairing. A few times, temperature was reported but nothing else. The configure button on the app does not do anything. I am requesting an RMA.


#8

I suspect it isn’t the device, but problems pairing and getting the proper configuration set. Which device handler are you using?

BTW, this is a super old post. Try searching for monoprice motion sensor and then sorting my more recent. These are discussed at length and work very well.


(Gary Davis) #9

I did not install any handler. I just searched for a device. It found Aeon Multisensor (even if I tried another like EcoLink). It then successfully paired (blinking LED went out) and then did not see any motion events. A couple times, the temperature did show up.

I will search for other related postings and look into how to use a device handler.

I am using the Window Phone app and also an Android app.


#10

Hi @gardavis. Even though it successfully paired, there are differences between manufacturers. Sometimes you can get lucky across different manufactures and a single device handler will work, like a zwave door/window contact sensor. In this case with the motion sensor, you’ll need something more specific.

I recommend searching, but to save you time, here’s the one I use: (phones don’t matter)

https://raw.githubusercontent.com/constjs/jcdevhandlers/master/devicetypes/jscgs350/my-monoprice-motion-sensor.src/my-monoprice-motion-sensor.groovy

If you’ve never installed a device handler, also known as a device type, be sure to read up on using custom code:

http://thingsthataresmart.wiki/index.php?title=Using_Custom_Code

The monoprice devices can be a bit finicky, but they do work very well. You may have to force the configuration to be set a few times before it works right. I think the other posts you find will tell you that too.


(Gary Davis) #11

After viewing the activity log on the phone app, I noticed that actually the device is detecting motion and temperature. There are some tiles that are not populated with info like humidity, lux and battery (all are zero). The configure tile does nothing.

Now that it is working, I will have to figure out what to do with it. I will cancel the RMA.

Thanks for the link to the handler. I see it should be easy to install at https://graph.api.smartthings.com/ide/devices (Click From Code tab and paste code - Save, Publish, Assign to the Device).


#12

Config tiles work in the background, and typically you won’t see anything change in the mobile app. It send configuration parameters to the device.

I would expect that because you’re using a device handler not designed for the monoprice device, so some tiles will never populate. Once you change to the proper device handler you’ll properly see motion, temp, and battery.


(Gary Davis) #13

I did install the MonoPrice driver and the tile set changed to only show temp, battery and refresh. Battery is 0% but maybe it will be updated later. The driver code looks like it waits a day before the 1st query for the battery level.


#14

Open the cover and let it sit that way for a few minutes. Then remove and put back the battery and wait a little longer. That should force a wake up and it should accept the configuration. Like I said, these are finicky.


(Gary Davis) #15

So far, no luck getting anything higher than 0% for the battery. Maybe it will show up some day.