Monoprice Z-Wave Motion Detector not working

It paired as an Aeon Multisensor + C3. It displays Motion all the time and there’s no data in the Right Now section. Is it defective or am I missing something? I’ve removed it and re-added about 3 times, I’ve rebooted the app and I’ve rebooted the Hub.


Try changing the Device Type.

I added the device handler from RBoy, it appears to be updated, but it still constantly displays Motion and no other data. :confused:

Have you done a z-wave repair since adding the device?

This can happen for a number of reasons, including the device being too far from the nearest repeating device.

Here’s a pretty standard FAQ for troubleshooting a device being stuck (although it says open/closed it could also be Motion stuck on:

I just tried the Z-Wave repair, no luck. I’ll try removing the battery.
I did make some headway by following some ideas in the thread below. It’s now displaying the temp and battery. Although the temp shows 66 degrees which isn’t correct and the battery shows 100%, so maybe that’s not correct either.

Removing the battery for 15 minutes fixed it! Thanks for the help Brian!

Now I have to get my Cree bulb working again.