Monoprice Motion Sensor Battery Level not Reporting

So I’ve read multiple times how much of a pain it is to get the battery to report but that it eventually does. Well, I’ve been trying for a few weeks without success. What am I missing or doing wrong, does anybody have a better device type for them.

I’ve got 2 of them, I’ve tried with the default “Aeon Multisensor” that it first pulls up as, I’ve tried 2 other custom device types people have posted in here. I’ve done the whole remove battery, remove cover, I’ve laid them right on the SmartThings box itself in hopes it was a problem with going through other zwave switches. But nothing I have tried has gotten battery to report. They have been sitting next to the smartthings hub for about a week and every time i look at the App i’m just disappointed :stuck_out_tongue:

First why is it so hard to get that to report, is the device not sending out that information at all. Are the device types we are using not querying this information correctly? Have they ripped out that ability from the device itself?

Just trying to get these things working before i go throw one up in the attic, heck they make very very nice temperature sensors :smiley:

As an alternative, does anybody know of any really cheap, reliable temperature sensors? I thought these might work great for a cheap device, but not being able to know battery level is a pain in the…

one out of five reports the level while using a custom device type. In the end, after my scheduled system downtime and another internet outage, I realize having it work locally with ST2 is more important than knowing the battery level. Now I’m back using the stock device type; 0 of 5 report any battery levels. Good luck with everything ( I know you’re probably unhappy with trade offs; but thats what ST is all about).

PS its not the device that is not working; in other automation systems that I have used with these same devices (HS & OH), they report battery consistently.

What stock device type do you use? Z-Wave Motion?

stock: Aeon Multisensor
custom: jscgs350 : My Monoprice Motion Sensor v2

1 Like

Sweet, thanks for the info. I’m trying to use stock device types whenever possible. I never even thought to try the Aeon with the Monoprice. Since My 4 monoprices never report battery either, I’ll switch them to the Aeon as I only care about motion and temperature. Battery would be nice, but as I said it don’t work for me on any of the custom device types.


Hmm I’ve tried a bunch of device handlers and didn’t really find any of them worked for me reliable so I decided to write my own.

However in total honesty I do charge for some of my apps (some are available openly for everyone on this forum), this however is one of them, so if you have access to my server you’ll have access to it. :smile:

need help tried every device handler on RBOYAPPS still Monoprice Motion Sensor Battery Level not Reporting

It’s possible you may have a defective piece.

Alternative move the sensor within 5ft of the hub, open the cover, wait 10 seconds and close the cover.

thanks, I used you instructions keep it 5 Feet from the hub

You’re welcome, glad the 5ft open/close trick worked for you. Z-Wave meshes are a tricky thing.

I have a Monoprice sensor that is not reporting any motion even if I use the RBOYAPPS DTH. I even tried to use another DTH and it does the same thing. I does show the proper battery level and Temp though.

Check the sensor sensitivity settings, how far is it from the nearest repeater or hub? Did you try bringing it closer?

Like I said it can see the temp and battery %. If I look at the device in the IDE it shows this as the current state
temperature: 66.0 F
battery: 100 %
codeVersion: 02.04.01
dhName: Monoprice and WAPIRZ-1 Motion and Temperature Sensor Device Handler

As you can see there is no Motion state. I have other sensors that are a LOT further away then this motion sensor and have no issues

That would mean the sensor never reported the motion value ever.
Things to try/check:

  1. Try to exclude and repair the device
  2. Motion sensitivity settings in the preferences page
  3. Take out the battery and reinsert it
  4. Check the motion jumper settings (there is a jumper inside the device, it should be not be connected to any pins)
1 Like

I went home and check it and although everything else is correct the motion light does not even blink so I think that it is toast