Monoprice In-Wall On/Off Module 11989


(Jim) #1

Hi guys, I’m completely new to this home automation stuff. Just got my Hub v2 for christmas and finally my first door sensor today. I bought an in wall sensor from monoprice (single switch). I was trying to figure out how to install the wires but got a bit lost. I tried to check every thread before posting one regarding this relay but can’t find photos or a video of the installation. Online there is a video but the guy already have everything inside the box, and I can’t see the connections. I have attached a few pictures of how I’m connecting the wire. I was able to get the sensor light (red) to blink but I don’t have not clue to find it or at least to make sure if it is connected correctly. Thanks in advance guys. I already have smartthings community in my daily forum check out lol…


3-way switch with z-wave relay
(Jim) #2

Hi guys, I finally found how to make it work.Here is a picture of the connections.

Black wire from module - meet the Live (wire with power) black wire at the switch
Blue wire from module - goes to the output on the switch
White wire from module - goes with white wires inside the box
Red wire from module - meet the Load (wire the goes to the light) black wire inside the box with a wire nut.

Green and Yellow. I believe is to connect another switch to the module. In the case you want to turn on two switches at the same time.


(Brian Gossett) #3

Jim - did you get this to work? The wiring you have used is sure different than the diagram that came with the device.

How did you get the hub to recognize the device? Did you take the hub to the device wired into the switch and then use your smart phone app to find it? What is the device manufacturer & type that worked?

Thanks.


(Jim) #4

Hi @bgossett, I was able to get everything the way that it is supposed to be. I’m attaching a picture of the connections. In the beginning I thought I had to have the switch “ON” always in order to work. But after reviewing the diagram a few times I realize that one of the cable was not connected at all. I thought it was for a second switch (even though this relay was a single one). Now everything is working great! no matter the switch’s position “ON” or “OFF” it always work manually or via smart app.

You don’t need to take the hub near the device (as vera, I believe does). Just leave it where it is.

In order to get it recognized was really simple. First get the relay wired. After making sure everything work (manually). Then you go ahead and open your smart app.- marketplace (things) - connect new device - it will start searching the device - 1 device found it will come up as monoprice (something) - select it - then you will that the light on the relay is going to go off. - then click “Done”

Now go to my home and you will see the switch (relay) there. Now it is time to test it to see if it work via the smart app.


Check the picture, if you have any pictures let me know.
Good luck!


(Brian Gossett) #5

Thanks for your help! I’ve realized my biggest problem was that I had reversed the connections on the switch.


(Jim) #6

Awesome! Glad i was able to help!


(Will) #7

Thanks for the pictures very helpful! Question, how do you have the red and white wire connected? It looks like the red is going to the switch but cant tell where the white is going.


(Jim) #8

The red goes to the load (4 LED high hat) and the white to neutral.


(Will) #9

Thanks! Time to set this up!


(Layton) #10

Hi there, I’m actually pretty good with wiring but I spent like 2 hours trying to get this thing to work yesterday to no avail. It’s possible I have a bad relay but just to be sure…The black gets pigtailed with the live wire coming in to the box, the red gets pigtailed with the load going to the light switch, the white gets pigtailed with the white neutral wires in the back of the box, the green is attached to the switch, and the blue is attached with the incoming black (live) wire to the switch? The one wire I wasn’t sure what to do with yesterday was the blue one. TIA


(Ray) #11

Assuming you have all the wires correctly identified. That’s the correct hookup for the relay. Just double check to be sure you got all the correct wires. You can also check the relay on a bench as well just in case your light wiring configuration is not something else.


(Layton) #12

Yeah, I’m pretty sure the wiring is correct too. I was able to get the switch to correctly turn the light on and off but I was not able to get it to turn on and off from the app. It connects to my hub no problem, it just won’t turn the light on or off even though I hear the “click”. Maybe I have a bad relay?

Also, I can’t remember where I read this, but I think I read some users having this weird issue where the relay doesn’t work at first, but after leaving it connected for a couple hours all of a sudden it starts to work. Has anybody else found this to be true?


(Jim) #13

If the dual relay was installed correctly. Maybe what you have to do is set it up via the hub. Follow this link

I have installed 3 in my house not problem. But keep in mind you have to setup this first.


(Layton) #14

My issue is with the wiring and connection of the single relay, I actually have the dual relay already installed in a couple locations and it works flawlessly, I even used the custom device type you have linked there.


(Jim) #15

Got it. The blue one goes with the black (live) too. I had the same issue.


(Layton) #16

Thanks, I thought I had tried that combo last night, but maybe not. I’ll try and give it another go today. Thanks for the response.


(Jim) #17

Great, let me know of if it work for u. The sole relay doesn’t need the custom device. The issue i had was that i had to leave the switch on always in order to work with the app (like a GE link bulb)


(Layton) #18

After doing some more research online I just ran across this line from the manual of the switch (which naturally I didn’t really read)…

Programming using the Program Switch

  1. Press and hold the Program Switch on the module for about 3 seconds.
  2. If the LED blinks once, the module is configured for a Single Wall Switch without Indicator Light.
  3. If the LED blinks twice, the module is configured for a Single Wall Switch with Indicator Light.

Apparently the default on this device is WITH indicator light (#3), which my switch is not. So I’m hoping that if I follow these steps and get the LED to blink once, it may solve my issue.


(Jim) #19

In my installation i believe i have two wires not connected. (Green and yellow)


(Layton) #20

So my problem turned out to be the issue I outlined 2 posts up. The device is initially configured to work with a switch with an indicator light so all I had to do was hold the program button down for 3-4 seconds and the relay started working perfectly. Installed 2 of them tonight in about 40 min and hope to put in a few more.