Moes (Tuya) Matter ZigBee Gateway (Model MZHUB)

I received this Gateway yesterday and have started doing some testing. I bought it sale at AliExpress for $23.50 US. I tested it with both Tuya and non-Tuya ZigBee devices.

Adding the Gateway to the Tuya app was easy. You scan the QR code on the back of the Gateway and it is quickly added.

Adding Tuya devises to the Gateway was easy. Adding non-Tuya devices to the gateway was hit or miss.

Adding the Gateway to SmartThings was challenging. You can generate a numerical Matter code or a QR Matter code in the Tuya App.

Using the Tuya QR code works but it requires the use of 2 devices. One to generate the code and one to scan the code. The Tuya numerical code usually hangs up and does not work.

The main problem I see is that when you added additional devices to the Gateway there is no way to get them added to ST without deleting the Gateway (and all connected devices) from ST and reconnecting it with the QR code. This will break all related automations when you do this. Maybe someone reading this know a better way.

The following ZigBee devices would no pair with the Moes Gateway:
a) Sylvania Smart+, dimmable, RGB-W bulb (Model 73693). This an older bulb and may be pre ZigBee 3.0
b) Ikea Tradri, 2 button remote (Type E1743).

The following ZigBee devices paired with the Moes Gateway but were not functional:
a) Sonoff button, SNZB-01 (And it did NOT show up in ST)

The following ZigBee devices paired with the Moes Gateway and were functional in the Tuya but did not get added to ST:
a) Ikea Tradfri, E1706 plug in smart outlet (pocket socket)
b) Tuya Gas Detector, Plug in style with EF00 clusters
c) Tuya 1 gang in-wall relay (MS-104Z) (ZigBee 3.0 & 433MHz)

The following ZigBee devices paired with the Moes Gateway, worked in the Tuya app, were added to ST, but did not work in ST:
a) eWeLink contact sensor.
b) eWeLink motion sensor (powered by micro USB and/or 2-AAA batteries)
c) SmartThings Multipurpose Sensor (IM6001-MPP01). It only appeared as a contact sensor in Tuya.

The following ZigBee devices paired with the Moes Gateway, worked in Tuya, showed up in ST, and WORKED in ST:
a) Sengled, Element Classic (E11-G13), dimmable warm white bulb. The bulb is dimmable in ST.
b) Avatto (Tuya) 2 gang in wall relay (WSM16?ZWSM16). It shows up as 2 separate switches in ST as it should.
c) Girier (Tuya), 1 gang in wall relay (JR-ZDS01)
d) Tuya Motion Sensor (Small round sensor with blue LED behind lens)
e) Tuya Temperature and Humidity sensor (NO LCD display)

This last group of items quickly update their status in the both app when they are operated.

As you can see the only non-Tuya device that worked was a Sengled Bulb. Makes you wonder if the smarts in Sengled bulbs are provided by Tuya.

Alexa - I could no link the Moes Gateway with Alexa

Google Home - The Moes Gateway easily connected to Google Home using the QR code. The same device carried over into GH as ST, but the motion detector did not work, and the T&H sensor was in °C not °F and could not be changed.

I use Android devices, so I could not test Apple Home.

As I test addtional devices I will update this post,

@JDRoberts @Mariano_Colmenarejo @Trakker2 @Andreas_Roedl

2 Likes

Related post.

So far, for most matter bridges, you add the device to its bridge, do whatever you have to do in the bridge’s app to indicate that you want that device included when a Matter connection is made to the bridge, and then you have to reboot both the matter bridge and the SmartThings/Aeotec hub and then the new device will show up in the SmartThings app.

At least that’s how it has worked for me with both an Aqara matter bridge And the SwitchBot hub two.

When done this way, all of the previous devices are preserved, and I don’t have to rebuild any routines.

I do not have this issue with Apple home or an Echo device that are Matter controllers. It’s just been an issue with SmartThings.

FWIW :thinking:

@Automated_House

4 Likes

Ok, I rebooted the Gateway several times, but I didn’t reboot my ST hub. I will have to try rebooting both.

1 Like

Thanks for the report! :sunglasses:

For those who prefer to shop at Amazon, it’s available there for around $50 and look on the product page for a sale coupon, they’ve been running a lot of them.

Also, one technical note: this matter bridge is advertised as supporting up to 128 devices, which is more than a different brand’s version of the Tuya matter bridge, so that’s good.

This seems to vary depending on manufacturer. My Hue bridge updates, albeit after a wait, while my Sonoff iHost updates immediately.
The Tasmota bridge does not update, but then again they state specifically that “Tasmota cannot be Matter certified”. Maybe this update function is specified somewhere in the Matter protocol?

2 Likes

I did some additional testing of the Moes Gateway today.

Based on @Johnnybegoode post I tried to sync the devices connected to the Moes Gateway to ST by only rebooting the ST hub and that works. It’s a pain but it works.

I tested the following ZigBee devices:

Avatto (Tuya) single gang in wall relay. It easily pairs with the Gateway and get carried in ST, and works in ST.

Ecosmart dimmable, color temperature adjustable bulb. It pairs with the Gateway, works with the Gateway, but does NOT show up in ST.

Tuya temperature and humidity sensor with LCD display. The LCD display shows temperature, humidity, time, date and battery. This is an EF00 device. It pairs with the Gateway, works with the Gateway, but does NOT show up in ST.

Tuya temperature and humidity sensor with LCD display. This LCD only displays temperature, humidity and a “baby face” it pairs with the Gateway, works with the Gateway, shows up in ST, but always displays 68°F and 40% humidity.

So to date I have tried 3 EF00 cluster devices paired with the Gateway and none of them work with ST.

So I would say that the Moes Gateway is NOT a way to get EF00 cluster devices to work with ST.

I have a friend who has some working, but they are all Moes brand devices. I know a lot of people think that shouldn’t make a difference, but there it is. :man_shrugging:t2:

That said, I haven’t heard of anyone getting a device with a display to work through the bridge.

1 Like

The box says it works with ZigBee and Thread devices, but I don’t have any any Thread devices to test.

Plus I have never heard of a Tuya Thread device.

Tuya introduced Thread modules about a year ago, but most manufacturers didn’t pick them up.

When matter 1.2 was being developed, tuya participated as a manufacturer partner and developed the first matter over thread smoke sensors for the Asian market. (They won’t work for the US market.)

Last month, Tuya also participated in the test of Matter 1.2 SVE including Matter over Thread Smoke and Carbon Monoxide Alarms, and Matter over Thread Air Quality Sensors. With the release of Matter 1.2, the two new tested product solutions will soon be available.

So I think they will get there eventually, but for now, their customers (the brand companies) are more interested in matter over Wi-Fi. :thinking:

Heiman does have a Tuya made matter over thread smoke sensor that just came out, the HS1SA-M. It’s identical to the Zigbee model, the HS1SA, except for the protocol being used, and many of the images on the product page are taken straight from the other model so a few even mention Zigbee, but it is indeed a matter over thread device.

2 Likes

Update on the Moe’s Matter ZigBee Gateway after using it for 17 days

The main problem I had was the I would loose all the bridged devices in SmartThings when the Moes Bridge lost power or was rebooted. Then you had the reboot the ST hub to get the bridged devices back. The devices came back with new generic names like Matter Thing. This would break the associated automations in SmartThings. This was not a workable situation.

I posted about this problem on the Tuyaos.com forum. I had a response in less than 12 hours. The reply said to update the firmware from the current v1.9.2 to v1.10.505. I went into the Tuya app and opened the device card. I found a notice and a button to update the firmware. The update was quick, but again wiped out the bridged devices in ST .

Since the update I have rebooted the Moes Bridge several times and have not lost any bridged devices in ST. So this seems to have fixed that problem, but only time will tell if it has totally solved the problem.

3 Likes