Add zemismart matter bridge to smartthings?

Trying to add the zemismart matter bridge to smartthings Zemismart Matter Zigbee Smart Home Hub AIBridge Matter Hub homekit google home voice control Pre-sale

I can either add it to Tuya and have control of devices (add/remove).

Or I can add it to smarthings and end up with zero control to add/remove devices.

What is the correct process to add this matter bridge to smartthings. I went into the TUYA app paired the bridge into Tuya. Then within the Tuya app chose share via Matter gateway. It generates a QR code that smarthings refuses to accept. I also do not see a manual method for adding this bridge to smartthings. Is it just me or does Matter seem like we are worse off then before when it comes to compatibility?

According to a comment in the fingerprints.yml for the matter-switch driver (which is where the bridge lives as well), vendor specific fingerprints are required for matter-bridges to be commissioned in ST and Zemismart is not among the ones available:

#Bridge devices need manufacturer specific fingerprints until
#bridge support is released to all hubs. This is because of the way generic
#fingerprints work for bridges joined prior to hubs being able to support them
  - id: "Aqara/m2/hub"
    deviceLabel: Matter Bridge
    vendorId: 0x115F
    productId: 0x0802
    deviceProfileName: matter-bridge
  - id: "Ubisys/G1"
    deviceLabel: Matter Bridge
    vendorId: 0x10F2
    productId: 0x6100
    deviceProfileName: matter-bridge
  - id: "Feibit/Matter/Gateway"
    deviceLabel: Matter Bridge
    vendorId: 0x117E
    productId: 0xFB01
    deviceProfileName: matter-bridge
  - id: "Yeelight/Pro/Gateway"
    deviceLabel: Matter Bridge
    vendorId: 0x1312
    productId: 0x0002
    deviceProfileName: matter-bridge
  - id: "QBEDFMB3/Gateway" 
    deviceLabel: Matter Bridge
    vendorId: 0x131E
    productId: 0x0001
    deviceProfileName: matter-bridge
  - id: "Philips/Hue/Bridge"
    deviceLabel: Matter Bridge
    vendorId: 0x100B
    productId: 0x0002
    deviceProfileName: matter-bridge
  - id: "Switchbot/hub2"
    deviceLabel: Matter Bridge
    vendorId: 0x1397
    productId: 0x07E7
    deviceProfileName: matter-bridge
  - id: "Nature/Bridge"
    deviceLabel: Matter Bridge
    vendorId: 0x138A
    productId: 0x1392
    deviceProfileName: matter-bridge

That being said, there is also an entry for a generic Matter bridge, but of type Aggregator (0x000E) as opposed to Bridged Node (0x0013):

matterGeneric:
  - id: "matter/bridge"
    deviceLabel: Matter Bridge
    deviceTypes:
      - id: 0x000E # Aggregator
    deviceProfileName: matter-bridge

This could be the source of the issue if the Zemismart is identifying as a Bridged Node (and there is no fingerprint for that deviceTypeId) and there is no vendor specific fingerprint either.

A little digging on the CSA website and I found the Zemismart hub which only showed up when I selected the vendor and device type of Aggregator vs Bridged Node. So, in theory, it should identify itself as an Aggregator. That may point to the early comment that specific vendor ID and Product ID are needed to add a bridge still. That info is in the screenshot below:

I don’t have time to add the fingerprint to the driver for you to test right now, but perhaps @mocelet does.

Website to search certified products is Certified Products Search | IOT - CSA-IOT.

What is odd to me is that if you add the zemismart hub to smarthings directly via QR it will add just fine as a bridge. But you can not do anything with it or add devices to it.

If you add it to tuya first then try to share as matter gateway then smarthings does not recognize the QR code as a device it can add.

Just to be sure: when you have a matter bridge, you would only be able to add devices to it from its own platform’s app. It was never intended that you be able to add devices to it from any other platform.

Instead, add or remove the bridged device in its own app. Then reboot the bridge and the SmartThings/Aeotec hub. The device changes should then be communicated to SmartThings and show up in the SmartThings app.

(It’s true that you don’t need an end Device’s own app if that device is individually certified for matter. But if the end device is not individually certified, like a Zigbee sensor, you have to get it set up in its own app first before it can be bridged to other matter compliant platforms.)

So are you saying that once you have added it to SmartThings as a matter bridge you can no longer add a new device to it from whatever app ZemiSmart uses?

Also… under the matter specification, a matter bridge, like the zemismart “matter hub” or the Aqara M3 is an “aggregator.”

A “bridged node” is an endpoint on the aggregator which stands as a proxy for a device which has been bridged by that aggregator, like, say, a Zigbee smart plug or a Zigbee door sensor. The bridged node Will identify itself with the capabilities of the device class of the end device that is being bridged.

So all of that makes sense. The zemismart “matter hub” is an aggregator which should have endpoints that act as “bridged nodes“ to represent the Zigbee devices being bridged.

Utility Devices
.
In the Matter specification, utility devices are special-purpose devices designed to deliver foundational services within a Matter network. Unlike full-fledged application devices, utility devices underpin essential network functionalities such as over-the-air (OTA) updates, power source reporting, introducing non-Matter protocols via the Aggregator, and bridging other devices with the Bridged Node.
.
Some notable examples include the Root Node, which outlines device capabilities; the Power Source, detailing power information; the OTA Requestor/Provider for managing OTA updates; the Aggregator for incorporating non-matter protocols over Matter networks; and the Bridged Node, representing a non-matter device bridged onto the network.
.
Utility devices serve as the backbone of a Matter network. They allow manufacturers to allocate functionalities across various endpoints on a device, thereby solidifying the network’s infrastructure and intrinsic features.

2 Likes

According to that comment in the source they’re no longer necessary, it was a workaround for old firmware versions of the hubs.

I try to avoid bridges but my Tapo H100 and their sensors don’t have vendor fingerprints, they’re not even SmartThings certified, and work fine.

1 Like

Correct. The only way I can add devices to the zemismart hub is if the zemismart hub is paired to Tuya. It appears I can either have it paired to Tuya or paired to smarthings but not both. If I pair the hub to smarthings I can no longer pair it to Tuya and vica versa.

For a Matter bridge, the procedure is:

  1. add it to its own app, in this case the Tuya app.

  2. using its own app, add the devices that you want to bridge, typically sensors and smart plugs, but it just depends on what that particular platform offers.

  3. you might have to go into each individual end device in that app in order to specify that you want it to be bridged. Or you might just go into the bridge device in that app and then select the end devices. It’s up to each manufacturer how they want to handle that.

  4. go into its own app, and get a new matter code for that bridge device. This is called different things in different platforms. It might be called “matter linking“, it might be called “multi admin“— again, it’s up to each platform what terminology and process they use.

  5. go into the SmartThings app, and add the bridge device (not the end devices) using the matter code that you generated in step 4. This should then bring in the bridged end devices that you selected in step 3.

Note that you cannot use the original matter code that you used in step one on the second platform. Regardless of which app you start from, Once a matter device has been added to a platform, from then on you have to use the multi admin feature in that platform to generate a new matter code in order to add it to a second platform. This is true for all matter devices, whether they are bridges or not.

This is because of the way matter security works. Once your device has been verified with matter, you don’t go through that same process again.

  1. after you have had the matter bridge working with the two platforms, if you then want to add additional end devices, like you bought a new Zigbee sensor, you have to go back to the bridge’s own app and add the device there. Again, select it to be bridged.

  2. this time, since you are still using the same matter bridge, you don’t have to add it in the SmartThings app. Instead, reboot the matter bridge device and your SmartThings hub and the new end device should then automatically appear in the SmartThings app and be available to use in SmartThings routines.

—-
I may be mistaken, but it sounds like you are trying to add the bridge device as a new matter device to two different platforms. That won’t work. You have to add it using its own app first. And then generate a “multi admin“ code for it from that app. Then use that new code to add it to the second platform And it will appear in both apps at the same time and be available on both platforms.

However, Because this is a bridge device and the end devices like sensors are not individually certified for Matter, you always have to add them to their bridge through the Tuya app. Then it is the bridge that will bring them over to SmartThings.

All of the above is true for any matter bridge, regardless of brand.

1 Like

I’m pretty much trying all possibilities because nothing works. I can add the zemismart hub to Tuya. There is an option to share the hub via matter gateway. If I click that it generates a QR code that smarthings refuses. There is no option to bridge individual devices.

I’m sure that’s very frustrating. It sounds like you’re taking the right approach.

First, just to get this out of the way, do you have other devices working via Matter on your SmartThings account? It might be worth quickly skimming the matter FAQ if this is the first matter device you’ve tried adding.

I know there have been some community members who did get the ZemiSmart Matter bridge working with SmartThings, but I don’t know the details except in one case the person did not originally have IPv6 support turned on on their WiFi router.

FAQ: What do I need to add a Matter device to the SmartThings app? Do I need a bridge router device?

If you do have other matter devices working on your SmartThings account, and the firmware on your zemismart device is up-to-date, but the QR code being generated in the tuya app is not being accepted, then you should get in touch with ZemiSmart support and see if they have any suggestions. :thinking:

Hopefully someone here who has it working will post more details.

In any case, as I mentioned above, you will never be able to add new Zigbee end devices to the ZemiSmart matter bridge using the SmartThings app. You always have to go into the app and add the new Zigbee devices there so that they can then be bridged into SmartThings.

One more thought… A lot of people have gotten tripped up because they selected “scan QR code“ before selecting “matter“.”

I personally think it’s a pretty confusing UI, but it is what it is.

  1. Start by choosing “partner devices/matter“.

Do not start by choosing “scan QR code“ or it won’t work.

  1. On the next screen, choose “matter” from the top

Do not choose the brand name of the device.

  1. Now you will finally get a screen where you can say you want to scan the matter pairing code.

——
Again, before starting these three steps, you have to add the matter bridge to its own app, select the end devices you want to bridge, and generate a matter pairing code for the bridge.

If you’re already doing the steps in the sequence, and it’s still not working, then you may have to get in touch with zemiSmart support.

if by chance you’ve been starting with the “scan QR“ code step instead of starting with the matter selection, try the process I’ve just detailed and see if it works. And know that you are not alone if that’s the issue; it’s tripped up many people. :face_with_raised_eyebrow:

1 Like

Frustrated yes!!! IMO Matter did the opposite of making things more compatible. Now its a giant mess of kludged setups and hacks. The only thing its doing is pushing folks towards wifi devices and Amazon/Google/Apple systems that do not require any of this stuff. Which is probably their plan and then switch to paid subscriptions. I’m not a big fan of wifi devices.

2 Likes

Interesting on my iPad there is no matter option

However on my iPhones there is

No luck

Ok, I think that’s the right path, now it may be a question of whether you’re on the same Wi-Fi branch. It sounds like SmartThings knows what it’s looking for, but it can’t find it.

I asked a couple of questions previously that I don’t remember seeing the answers to.

Is this the first matter device you’re adding to your SmartThings account?

Did you get a chance to skim through the matter FAQ I linked to ? it has a link to a Google URL which will test whether you have IPv6 support.

Also, I don’t know about the Tuya platform, but on most of the matter compliant platforms the multi admin matter pairing code will expire after 15 minutes. So you do have to complete the process within that time. Again, it’s a security thing.

Troubleshooting Steps for failing to connect a Matter Device with another smart home platform | TP-Link.

And, yeah, Matter setup is painfully annoying right now. Definitely not what we were promised. :rage:

btw, The screenshots in my previous post were from my iPad, so I’m not sure what’s going on there…

Also, what model SmartThings hub do you have and what firmware level is it at?

I dont use wifi unless absolutely necessary. Both the Smarthings Hub and the zemismart hub are connected to ethernet. My phone is on wifi because it doesnt accept ethernet :slight_smile:
The Zemismart hub only accepts zigbee and thread devices not wifi devices.

I did read the IPv6 thing that looked to be for matter devices on wifi. It would seem dumb and short sighted to require IPv6 JMO (that is just making things complex to be complex). I have no Matter devices on wifi. But no I do not have IPv6 routing enabled on my pfsense router. That was done intentionally.

IPv6 is required for all Matter devices, either actual or spoofed. It’s part of the specification. (Matter was originally called Project ChIP, Where the IP was for IP addresses.) that’s true whether they are connected by ethernet, Wi-Fi, or thread.

That’s detailed in the community FAQ:

FAQ: What do I need to add a Matter device to the SmartThings app? Do I need a bridge router device?

Technically you should be able to use Matter with Ethernet only, no WiFi, but that doesn’t mean zemiSmart and SmartThings are set up for that option. And it’s still using IPv6 addresses.

which model SmartThings hub do you have?

2 Likes

Matter is an IPv6-based protocol

1 Like

I have the Moes (Tuya) Matter Gateway.

I added it to Tuya app, generated a QR code in the Tuya app on my android tablet and the scanned the QR code in ST with my android phone. I could not get the numerical code to work.

To get the Tuya ZigBee devices to show up in ST, I have to reboot the ST hub every time I add a new device.

1 Like