Mode Changes Stopped Working with New Router


(Art Solanes) #1

I was having problems with my previous router from Frontier not being able to keep up with all the devices I have put in the house. Frontier mailed a new router which was installed and named the same as the previous one and with the same password. Everything linked up successfully and works fine. When first installed it kept saying I was away, then home back and forth for an hour or two. Now, it shows/triggers if roommate leaves and arrives but always shows ‘away’ in my home->things but regardless of if he’s home or gone, it shows him as ‘away’. It records him when he leaves/comes home but never changes from ‘away’. However, in my case, it shows me as ‘away’ all the time when I leave or come home but shows no activity on things->device->recently. In the past, with the previous router, everything worked perfectly. Any ideas?


(Bryan) #2

Maybe try removing and then re-adding the sensor.


(Art Solanes) #3

The sensor is my Pixl phone.


#4

Most likely this has nothing to do with SmartThings and you would see the same issue with other Geo location apps, even google maps.

We were just talking about this last week, it has to do with when the location of your router and mobile gets updated to the various Geolocation data bases. It happens all the time to people when they move from one address to another but take their old router with them. In your case, your mobiles probably still think they belong to the old router so they are “away” from it.


(Bryan) #5

What JD said may be true. But it wouldn’t hurt remove and then re-add the phone as a presence sensor.


(Art Solanes) #6

I did exactly that. I required re-entering my sensor on all the smart apps. It worked great! We then proceeded to my roommates. At first it showed present and all is well. Then went back to away mode although mine is working fine. We both own the same phone with same settings. We will remove and re-enter again for the third time. Kind of frustrated. Will keep you posted.


(Art Solanes) #7

Ok… this is going to sound crazy. Just to point out. I do have location on to high accuracy etc. I got on maps, hit home and it started working again. Thank you all so much for your help and input! It was honestly appreciated and you guys are always there when I get stumped! Again, thanks!


(Bryan) #8

Can you describe a bit more about what you mean “hit home”. I’m curious what you did that fixed it.


#9

The OP is using the pixel phone from Google. I’m pretty sure that uses the same location services as Google maps. So this, although the UI may be slightly different:

https://support.google.com/maps/answer/3093979?co=GENIE.Platform%3DDesktop&hl=en


(Art Solanes) #10

Thanks! I do have that set up. I increased the geofencing and it seemed to help. I think the router is between two towers that is shifting my position.

Art S.


(Omojo) #11

Thanks JD,

Any remedy to solve this issue

Sent from Yahoo Mail on Android


(Art Solanes) #12

I went on Google Maps and have Home preset on maps. I tapped home and Smartthings recognized I was home, temporarily. Non of the issues have really gone away. I will have to reset a lot of setting with imagination to work around this. I set many features and Security system around modes of ‘home/away’ via presence. This is certainly a big step back in enjoying the system, obviously. Thanks for your interest.


(Art Solanes) #13

I added and removed a few times. . No change.


(Art Solanes) #14

I have an idea. What if I were to buy a router like Netgear Nighthawk. Maybe a stronger router with better coverage will help? Just a thought.


#15

Did you get a chance to read the article I linked to? If This is also affecting your other apps like Google maps, then This is a very common issue when people either get a re-issued router , as you did, or when they move and take their old router with them. It will solve itself over time without you doing anything at all.

If you want to force the databases which are used for this to update sooner, you need to contact support for both your mobile phone service and for your ISP.

You can buy a new router if you want to, and as long as you change its SSID that would probably solve the problem also, but that would be an expensive way to solve what is really just a bookkeeping delay.


(Art Solanes) #16

I’ll wait it out. Just frustrating walking out of the bedroom at 4:30 AM and have sirens go off! LOL. I did notice on maps that I am outside of the house and the rings of coverage of the router fluctuates in size. Sometimes I’m within that ring and sometimes not. Thats why sometimes I’m in and out of the house/ring throughout the day/ night. Usaually outside setting the away mode on. That’ why I considering larger area of coverage.

Art S.


(Daniel Marcotte) #17

the ring around your house must be very large to solve the problem.
for me it is 0.6km. So it include a large area.
When you are inside your home, your phone cannot use GPS for a precise location, it use cell tower to APPROXIMATE your location.

how to enlarge the ring : in SmartThings Classic on your phone, hit the 3 horizontal bar, then the dented wheel (setting).
A more powerfull router will not help.


(Art Solanes) #18

You were dead on! Thank you. As days passed it worked as expected. Now it’s flawless once again. Thank you!! Next project, replace Nest Cam with Samsung HD Pro. I’m tired of paying a yearly fee.