Moving Home location


(Adrian Parker) #1

Morning all,

Some advice on the below would be great please. I’ve just moved house so have obviously taken all my ST gear with me. Same gear, same hub, etc. I’ve got Internet connectivity using same router, WAP, etc as before and I’m able to control devices as before. However, the presence detection of my Android device is now permanently shown as Prevent.

Once all plugged in and working I updated the location of my home hub via the app. This shows as correct on the app now and also when I log into IDE. Despite this my presence was always shown as Away. As a test I went back to my old property and it updated to Present. It’s now stuck in this state. Phone has been rebooted, cleared cache and data but not change.

Any ideas? Thanks guys


(sidjohn1) #2

(Adrian Parker) #3

Hi @sidjohn1, this has been done but isn’t working


(Flip Taylor) #4

Have you tried adding a new location for your new home then deleting the old one?


(Edward Pope) #5

Android or IOS?

I thought that the presence sense through the phone captures the MAC of the hub, so it may still think you are at your old location. I have heard that changing the MAC (some routers support this) or purchasing a new router sometimes resolves this issue.

I have not personally run into this issue, as I have purchased a new router each time I moved, as I leave the network setup at the old location to assist the new owners


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #6

I doubt this, but who knows. Any evidence or statements?

I thought SmartThings App mobile presence is based entirely on the phone’s geo-location service; though using other local clues might not be a bad idea. I just don’t think it’s there.


(Jason "The Enabler" as deemed so by @Smart) #7

I’m sure you have fine this already, but have you tried going to the dashboard, my locations, settings and seeing what is on the little map?

If that’s wrong, that may be your problem.


(Edward Pope) #8

As stated I personally have not run into the issue myself. I have seen others complaining about it on other boards in reference to Android and how Google determines location. People have replaced the router with a new router and presence starts to work correctly. It is assumed it was due to a change in the MAC Address, but it could be as simple as changing the SSID.

Like I stated, I have not run into this myself, just trying to give some options. Especially when he stated it seemed to detect him back at his original home location. Which, honestly works against the MAC idea (SMILE)


(Adrian Parker) #9

Hi @bamarayne, yes tried that. It’s fine in the IDE. I’ve made my capture area larger and it seems to have made it worse, multiple Goodbyes and I’m Back overnight


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #10

Yup… Sorry to have seemed to shoot down your theory summarily… Everything’s worth a try.

You piqued my curiosity, that’s all. SmartThings presence is such a fussy thing that I’m quite intrigued when I hear it might be based on something that I didn’t know… :smile:


(Edward Pope) #11

I really wish they would fully explain how it works, so that when things like this come up there would be some steps to basically troubleshoot the problem. @Tyler or @tyler1 any chance either of you could clear that up. Just what does ST use to determine presence?


#12

Mobile Presence is based on phone geolocation - nothing related to the hub.

In the mobile app you define your geofence. Your phone reports a distance from the center of that geofence. That, together with the radius of the geofence determine if you’re home or not.

It sounds like this issue may be caused by Google/Apple caching the location of your router. That’s how they determine where you are. We’ve had numerous customers email us after moving and the issue always resolves itself after a few weeks.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #13

Ooooo… That’s right! Google’s little Streetview cars also go around and snoop folks WiFi SSID’s. Someone ruled that was not private information … I guess it’s like reading your house number.