Mobile Presence sensor always 'Present'


(Greg) #1

I’m not sure when this started, but I realised that I no longer get push notifications for my ‘Goodbye’ routine. After looking into it, I realised that my lights never turn off when I leave and the Goodbye routine never triggers.

I’ve tried to figure out what’s going on and today I realised when we were out that neither of our phones are always ‘Present’ even when they’re not at home.

We’ve both reinstalled the app, and checked our location settings but everything is fine. All I can suggest is that the new app has a bug in it, or there is something else going on.

Has anyone else got this problem and how did you fix it. It’s driving me mad.


(davedogcaddy) #2

Same problem here. Both phones have been ‘present’ since the 18th! I started out thinking push notifications were broken (see thread I started on this subject). I’ve since discovered the issue with the phones. This morning I’ve re-added the phones and deleted the stuck ones. Now they seem to be working again. I’ll have to wait until we both leave to see if the system goes to ‘away’ mode like it should and gives us push notifications.


(davedogcaddy) #3

Also noticed today that one of my motion sensors has been stuck on the same state since around the same time the phones got stuck. So you may want to check your other devices. This is likely why I wasn’t getting motion push notifications as well. Ended up having up pull the battery from the motion sensor for a minute, reinstall then the sensor went live again. This is the first time I’ve really has any issues like this with any of these devices. Waiting for the laundry to finish to see if those notifications work again. Crazy it all broke at once… Wonder if the recent app/hub updates have anything up do with it…

Edit: realized my multi sensor on the washer was stuck too (stuck on active). Pulled battery, reinstalled. Working now. It’s all starting to make sense now why no notifications.

What the what!


(Greg) #4

My motion sensors and everything else appear to be fine. Its just the mobile app it seems


(davedogcaddy) #5

Try removing the phones and adding them back via the app, that appears to have fixed it for me.


(Greg) #6

How do you remove them? Seems they’re added automatically when you sign in no?


(davedogcaddy) #7

Click on the device, click on the gear, there should be a remove option at the bottom of that page. A tip, i re-added the phones before I removed the dead ones. This let me add the new working phones into my SmartApps, then I removed the dead phones from the SmartApps, that way I didn’t have to rebuild the SmartApps. You can’t remove the phones if they are currently part of a SmartApp. Hope this makes sense. :joy:


(Greg) #8

Ah. Just managed to do this although the thing just makes so sense.

Mine now says “Arrived at 17:08 25/09/16”

My girlfriends on mine just shows the Present icon, but on hers, the away icon. No message about when it left or arrived…

ARGHHH


(davedogcaddy) #9

It shows it arrived because as as far as SmartThings is concerned it DID just arrive (it’s ‘new’) :grinning:

Did you re-add her’s (using HER phone), and then remove the old instance of her phone/device?


(Greg) #10

Yep twice, managed to get it working now.

Removed her phone and readded it. Still didn’t work. So signed out and uninstalled SmartThings. Reinstalled it, signed back in and it works


(davedogcaddy) #11

YAY! glad you got it. :slight_smile:


#12

This problem gets frequent discussion in various threads on this forum. I try to read all I can about it trying to see if I can ever spot a common denominator. So far, I can’t say that I have other than I appears to be more prevalent with Android vs iOS. I could be that this is just due to the number of android handsets vs ios. I can’t help thinking that there has got to be some commonality to the problem.

So far, I can’t contribute any personal observation. I’ve been using 2 iPhones as presence devices since I got SmarThings with no problems.


(Ben Lebson) #13

Restarting my phone has solved this issue in the past.


(Greg) #14

Unfortunately I think this is more a server issue if i’m honest.

My girlfriend got a new phone, uninstalled ST from her old one, installed it on her new phone. Presence did not work, and it hasn’t worked until I’ve just removed the device and reinstalled the app…


(Ben Lebson) #15

Presence is tired to the hardware, not the account you logged in to. If you get a new phone you need to replace the old one. It’s similar to it you were replacing a motion detector or something similar.


(Greg) #16

Hmm, then the app is borked given mine just stopped working on my existing phone.

As above, even when I readded my gf’s new phone it still didn’t work, until i removed it, uninstalled the app and started again


#17

Removing and replacing the phone when getting a new handset is not an absolute. Not being an android user I can’t speak to that process but when replacing and iOS handset you only need to restore the new handset from your backup in iTunes and it picks right up where it left off.


(Ron Sissons) #18

I cant add the same phone, it gives a warning saying it already exists.


(Phil) #19

Also make sure you give the app to access your location at all time.