App Update V2.4.1 - Presence Sensor


#1

Since the latest app update, version 2.4.1, smartthings has been reeking havoc with the presence sensors. For some reason smartthings is running programs triggered by the lack of a presence sensor, even while all sensors are still home. Example being that smartthings will show I am home, however launch a goodbye routine that should only be triggered when no one is home, arming the house and turning off lights. However when I look at my mobile device under the family tab it will have show me at home the entire time. Almost as if it thinks I left, even though it acknowledges I never left. Being that none of my routines have changed and this problem just started happening I have to contribute this to the updated app.

Note that I have reset my hub and the phones, yet the issues still remain. Anyone else experiencing this? It is happening both on my iphone and my wifes android.


Presence doesn't work on wife's phone
Mobile device presence broken with iOS 11
Smarttings Hub thinks my iPhone is "Home" but it is not
(might be my fake name?) #2

iOS or samsung?


#3

The version 2.4.1 was for ios, however the update went out to both ios and android.


(might be my fake name?) #4

I have updated to the latest (iOS) and have not experienced any issues with incorrect presence reporting.


(Squatting Hen) #5

Issues I have, doesn’t matter the update is that I leave and it still thinks I am home. Or I leave and come home, after being gone over an hour or more, and it says I never left.

For example…right now, I left the house over 1.5 hours ago, and I am nearly 30 miles away, but the app says I am still home.

I love that I have to manually control my home automation.


(Megan) #6

My son is on droid and it keeps saying he leaves and comes back like 5 min later, but the whole time he is still home.


#7

Anyone have troubleshooting for this? Seems to be a prevelant problem.


(Squatting Hen) #8

Supposedly this is just part of how it works, or doesn’t work. The blame tends to get pushed to the phone and geo location, even though other apps seem to be a bit more reliable. I don’t get it, nor do I like it, as we heavily rely on the presence to automate our house. Even though this seems to have been an issue for quite a while now, I truly hope it is still being looked at and worked on, and not just accepted as is. My fear though, from reading between the lines of the comments of “how to help”, is that we just have to accept it, as there is nothing additional ST can do. I really hope that isn’t the case.


(Bob) #9

There are numerous threads regarding presence issues for both ios and andriod going back over numerous builds.
I have an Android, Samsung S6, and I have found that disabling battery optimisation and stopping apps going to sleep, a feature of Android, has made my presence issues virtually go away.
As an aside if I go into ST settings and have the location map open, I can see may presence moving around (not by much). This is not, I would suggest, an ST issue but more the way the phone triangulates your location.
PS. I had the same issues with my Tado presence detection.


#10

Different problems, different causes

If SmartThings thinks you left when you are still home, that is almost always a problem with SmartThings, or at least SmartThings struggling to overcome local interference.

If SmartThings thinks you are still home when you have actually left, and you are only signed in on one device, that’s almost always a problem with your phone not reporting its new position, and that will usually affect multiple apps, not just SmartThings. The problem is that as soon as you open an app, your position will probably be updated, which makes it hard to prove that other apps aren’t having the same problem. So in order to troubleshoot this one, you have to set up a non-SmartThings app that also tracks you over time. The free life360 app is a good choice for this and has an official SmartThings integration. If it’s taking a long time to update your position, then to improve things you start looking at your own phone settings and use patterns.

If the problem is that you can’t set a Geopresence region which is working for you, but SmartThings is responding appropriately when you cross the region boundary, then you may need to switch to a different type of device or to a two-device system.

How important is presence to you right now?

I would also note the people seem to fall into two groups when it comes to troubleshooting presence problems. Both are legitimate. They just represent a different current need.

The first group is people who just want the SmartThings official mobile app presence to work the way it’s advertised. They don’t themselves want to spend much time on troubleshooting, they don’t want to look at alternative methods, they just want it to work the way they expected it to when they bought the system. Again, that’s an entirely legitimate position. For them, there are really only two things they can do: contact support and see if support can make things work any better, or try the SmartThings – branded presence sensor rather than the phone.

The second group is people (like me) who really need presence to work now because of requirements they have for their home automation system, and are willing to spend more time and money to come up with something that will work. (In my case, I am quadriparetic, use a wheelchair and have limited use of my hands. I need presence that works, even if it’s cobbled together from multiple systems and devices.) The good news is that there probably will be a way for most people to end up with presence that does work. The bad news is that it’s going to require some trial and error testing, it will probably require additional devices or apps, and it’s going to take time to get it set up right. Again, in my own case, it took about four months to get to the point where I had reliable presence detection. It was worth it to me, but I understand completely that it wouldn’t be worth it to a lot of people.

More information in the presence FAQ:


#11

I contributed this to an error with smartthings updating the mobile app as that was the only change with my setup. The phones, devices and routines have been working perfectly for the last 6-8 months since I set it up. The app updated and I began having issues.


(Brad) #12

Updates to 2.4.1 went out for Android and iOS though they target different things from the 2.4.0 release.

Please send in your mobile presence logs if you’re having issues.


(Squatting Hen) #13

@Brad_ST

Thanks. I know your reply was @Ekeenan86, but can I safely assume anyone having issues can send in the logs?

If so, I am fairly new here, can you direct me to the best/proper way of sending in these logs?

Thank you.


(Brad) #14

Yes, you can assume that. :slight_smile:

On iOS:

  1. Tap More
  2. Tap Support
  3. Tap Help us Debug
  4. Tap Send us only your Mobile Presence logs

On Android:

  1. Tap the 3 vertical lines to open the overflow menu
  2. Tap Support
  3. Tap Help Us Debug
  4. Tap Send Geofence

If you can add an approximate time when the presence failed and what kind of failure (, it will help us narrow down our search in the logs.


(Squatting Hen) #15

Awesome. Thank you. Sent my first log. For better or worse…you guys might be seeing more logs from me now that I know how to do it. :slight_smile:


#16

Thanks Brad for the follow up, I have sent over the logs, specifically 6/24 was when I noticed the biggest issues with the presence sensor being way off. Let me know if you need more info.

Thanks,

Erik


(Squatting Hen) #17

@Brad_ST I sent logs on Monday because my phone was showing I was home even though I was nearly 30 miles away.

Now…4 days later…My phone is showing the exact same thing along with the other phone in our Family. Both have been away from the home for over 2 hours, both over 30 miles away. If I open the app and give it time, it will refresh my status, but I have to reach out to the other person to do the same.

Nest shows we are in Eco/Away mode.

This is where it doesn’t make sense. It does seem like there is a “timeout” setting were it stops working after a few days. It has been fine since Monday, until today. I open the app numerous times a day as well.

I sent logs in again today, but last time I received the standard response about how phone’s presence sensors are not perfect, but to check settings… Hopefully these filed reports do make it to someone who can actually use and improve with them, not just to the representative who responds.

*It would be nice if there was a way for us to have ST refresh the “ping” to the phone from within the app. The pull down refresh doesn’t help. That way I could ping it for everyone when it gets stuck like this, and not have to reach out to them and have them open the app.


(Brad) #18

I found your ticket and flagged it for more attention.

I took a look myself and it does seem the app is failing to update the GPS when it is moved to the background.


(Squatting Hen) #19

Dude… You might be my new superhero. That is awesome. Thank you for looking at it further. I realize things take time to get fixed, but from experience, the most difficult step is having someone listen and look into the problem. Thank you for taking it a step further. I truly appreciate it.


(Bob) #20

I have the same issue with my wifes S6 at the moment.
Do you want me to raise a ticket or just follow this thread for a solution.