SmartSense Presence Sensor never leaves


I’m pretty new to SmartThings, having recently bought a V2 system in the UK.
I’m having a couple of issues that I’m wondering if anyone else has seen.

The first is that the presence sensor bundled with the hub is always reported as present, even if it’s several miles away. I’ve checked the battery, which is okay. I can also make it beep, so as a minimum the receiver is working. It did work fine for a few days and then just stopped. I’ve tried removing it from the system and re-pairing. The re-pairing worked fine, but I get one message in the log to say that it’s present and then nothing after that, even if it’s miles away.
If it showed as not present I’d just take it back, but the fact it never leaves made me suspect a software issue with the hub. However, I’ve completely reset the hub and started from scratch, and again it paired okay but no more log entries after the first ‘present’ message. Should I just return it?

Second issue is the built-in ‘Goodbye’ smartapp does not work with my Android phone unless I’m logging in the IDE. The log contains a message to say the phone left, but the actions aren’t performed unless I’m logging?! The ‘I’m Back’ works fine. Any ideas? I’ve yet to dig to far on this one, as I only found it works when logging late last night.

Cheers, Jon.

1 Like

I should have looked harder - I found a thread covering the presence sensor issue here: