Mobile presence not working on Smartthings app 2021 (ver

I enable “Get location from this phone” on the app on a Galaxy S20, I see the device being added in the Smartthings IDE, but it does not get assigned a “Device Network ID”, the Type is equal to “placeholder”, and of course presence does not work.

I deleted the app, deleted the device, restarted my phone, reinstalled the app, re-enabled “Get location from this phone”. Same thing. No luck…

Please fix!

That is normal with the presence sensors now.


Try turning off get location in the ST app
Remove the app
Remove any existing presence sensors for you in IDE
Reboot your mobile device
Reinstall ST app
Enable get location and hope for the best :slight_smile:

But sounds like everything you have already tried except turning off get location first in the app before the other stuff.

1 Like

I have the same issue. Do you have an open track w st?

Same issue here. There’s no way to make it work.

Interesting… I have an S21 and presence is working for me. I did have it setup prior to the Hub FW update to 37.04 and prior to the newest ST update (which happened Sunday, 6/20 for me) …

I am using Home Monitor (even though I have NO security or motion sensors currently), and the “Welcome Home” Labs Smart App. Kicks off a few outdoor lights and (of course) sends me a cute little “Welcome Home” text. LOL.

Just a thought, but did you check that your “Location” settings for the Home/Hub are still intact in the IDE (manage Location) ???

My presence stopped working today
S21 android

Wife’s IOS iPhone still works. Only my S21 android stopped working

I have a total of 4 members in my household - all of which are iOS. For the past couple days - it will only register 2 of the 4 leaving or arriving. I will be toggling the location services for the 2 that are not working. Apps are already updated. Anything else I should try?

I logged Out of the app. Uninstalled and reinstalled. Activated all permissions such as location. Still doesn’t work.

So I will reactivate my life360 presence and see if is working. If the life360 presence is working…I will use the life360 for the time being until ST rectifies this

Yeah it’s just weird that it’s 2 of 4

I have one phone that was unaffected by the Android app upgrade when it comes to presence events on either of two locations, or indeed by an Android 11/ OneUI 3.1 upgrade. However I notice another hasn’t shown any presence events for the last seven days and I’ve just tried disabling and enabling the presence again. That one runs SmartThings unattended, as it were. It is the first time I’ve really seen issues with presence since the new integration was introduced on Android last year.

To rollback to previous versions of smartthings go-to click on APKS then goto smartthings. Recent version is


I uninstalled and installed the Previous version

This has worked in the past for Smartthings Classic when app updates were messing up and not operating correctly.

I won’t know until I get home to see if my presence starts working again

Try that

I just got home and presence is WORKING again…using version

I had the same problem with IOS and was able to fix it by changing the device type to “Mobile Presence” on the API site.

1 Like

Yes, thanks for this hint. Worked for me as well.
I temporarily changed the device type to “Mobile Presence Occupacy” and then back to “Mobile Presence”.

How do you do this via ST IDE? When I open the device to edit (Device List > Edit Device) and switch the ‘Type’, the ‘Device Network Id’ field remains null. Should I manually assign a value or is there a method for updating the Type value to allow ST to auto-set an ID?

Tagging @Glo6ox since they also seemed to get this to work.

Thanks in advance for your time and advice.

I would seriously recommend not changing the device type to mobile presence. :slight_smile:

Any ideas on how to resolve the issue? The device type and missing ID seem to be the reason why the phone cannot be added to webcore (since my other mobile device in webcore has both a mobile presence type and assigned ID). Not sure how to proceed. :man_shrugging:t3:

Did you open your instance of webcore in the ST app and select the presence sensor in settings > available devices > capability group 2 > presence sensors?

No, but that did the trick! In webcore, I had only been using the main Select Devices by Type > Which sensors. I was not aware of this alternate capability group. Thanks for the advice. Much appreciated!