Mobile App Login Blank

I’m in US and my mom is visiting me from China. To help her use my smartthings, I downloaded Smartthings app from Chinese Apple App Store. After entering my email address when login, the app page redirects to “” and shows “Continue with Applicable service: Smartthings IOS”. And after clicking “AGREE”, the app login to a blank page without anything else.

At first I thought this is because the app was download from the Chinese App Store. So I deleted the app, switched her app store account and re-downloaded it from US Apple App store. Also the location of the phone setting was switched to US and the browser history/cache was cleared as well. But when I tried to login again, I eventually got the same blank as before. Tried a couple times without any progress.

I also tried to log out smartthings app from my own iphone (not my mom’s above), and then re-login, everything just works fine though.

This is so frustrated and please help. Thanks

The new “Samsung” login has caused various bits of trouble for a lot of folks, including SmartThings customers attempting to use the App on Amazon Fire Tablets since it can’t find the Chrome or Safari browser…? Personally I have a very old account, so perhaps I’m lucky not to be tangled in this.

I recommend you contact or chat with

However, to help your Mom easily control your Things, may I recommend configuring a simple web-based ActionTiles Panel for her? You can use any valid email address to create a master account for yourself (to link to your SmartThings Hub … heck, do this on a PC or Mac or tablet…), and then you can Share to her personal ActionTiles Account.

Start at to set yourself up. Our web-app is free for 14 days Trial (then $23.99 per SmartThings Hub … unlimited users and devices at this time).