Missing device on Alexa routines


#1

Just starting to use routines and I’ve found a bit of a problem.

I have three relays which control garage doors.

When I look in the list of devices under smart home on Alexa They are all listed fine. I can access each one and press the switch, door works just fine.

When I create a routine and go to the list of devices, one is missing and another is listed twice.

Screen shots below.

List of devices in smart home three relays at bottom all present and correct:

When choosing a device to control in routines, number 3 listed twice and number 1 missing alltogether:

Any ideas?


(Rick S) #2

Good luck, I have the same issue, posted it a couple of times and no replies

I have 2 missing, one with the wrong name and 1 that I have no idea where it came from

Also don’t see a way to update the device list

Good luck
Rick


#3

You can update the device list by going to “add device”, the Alex a app then scans for devices.

I’m going to try removing all three relays in ide, removing the link from Alexa to smartthings, re-enable the skill and scan for devices, hopefully it won’t find them. Then add the device back to smartthings one at a time.

It’s a pain in the backside because I have to edit the settings for each relay so they are only on momentarily to simulate a button press.

Too cold, dark and late to bother doing it now. Though slightly annoying that yet another piece of technology has been released half baked. Why one list of devices in the smart home menu and a different list in the routines section…


(Rick S) #4

I have tried to scan/discover devices from every which way, no luck

Rick


(Tyler Durden) #5

What is the “Description” displayed when you click on each of the duplicate devices and choose Edit?


(Rick S) #6

The one with the name that I don’t know where it came from, I deleted. The device that is missing, let’s start there, how to get it to show in the device list?

Rick


(Tyler Durden) #7

Have you authorized the Alexa SmartApp in ST to access the missing devices before you rediscovered in Alexa?


(Mike) #8

Since this latest Echo update Amazon removed the ( Clear all devices ) option, which made it easier to start over BUT there is a way as Echo also has a web app using the old Echo software interface, this had the ( Clear all devices ) option at the bottom as it used to be
https://alexa.amazon then i guess its .com if you are US based and .co.uk if you are Uk based, log in from a Pc and the old interface is offered


#9

Duplicate devices only show up in the list of devices displayed when choosing what device to control as part of a routine.

When viewing the devices on the “smart home” menu in Alexa app the devices are all listed correctly. There are no duplicates in this list and the three individual relays can be controlled just fine from this page.

Try and create a routine and one of the devices isn’t displayed and another is duplicated.


#10

Success.

Using the web page for Alexa noted above and telling it to forget the devices in question and telling alexa “discover devices” got them refreshed in the list.

They then appeared in the list of devices available to routines.


(Ron Talley) #11

Good for you. I have about 15 devices that she refuses to find and all of my ST devices went offline. Some of them I could control. Some I couldn’t.

Something is all wrong with the new Alexa API update. Just all wrong.


(Rick S) #12

Yes the Alexa Smartapp is installed and ready to go. I have several other devices showing in the Alexa device list but a couple or missing. I have tried to discover devices both in the Alexa app and directly through Alexa directly

Rick


(Barrett) #13

Once you get to the screen where your devices are listed when making a routine, have you pulled down the screen to do a refresh?

I hate to ask for such a simple thing, but I had the same issue, and it took me a day to realize I needed to manually refresh the list. (Should be automatic imo)


#14

Thanks for this tip…it worked perfectly…