Alexa can't find on of my routines

As of about two nights ago, Alexa can’t seem to find one of my routines. The others she finds just fine, but this one is lost. It’s still showing up in her smart app, and it works if I run it off the mobile app, but she just bonks when I try to run it through voice.

I’ve removed (and actually rebuilt) the routine, then added it back into her smart app and had her re-discover it. I actually had her perform device discovery without the routine’s virtual switch, and she came back one device short, then I added it back in and she reported back the correct amount of devices, so I know it’s in there, but she can’t seem to find it.

Anyone have any ideas?

For this i’d recommend contacting support,

Keep in mind the Official integration for Echo (the one that we support) does not support routines at this time.

New well in that case there is the developer of the smartapp that adds routine support :wink:

1 Like

What’s the exact name of the switch Alexa doesn’t find?

And what’s the exact behavior when Alexa doesn’t find it? Does she say anything or just turn off

And when you check History in the Alexa app, what does she think you said?

Alexa does reserve some words for her own use, and overvtime occasionally does take back some words which used to be available.

For example, I originally had a switch called “power” I used this for over a month. I could say “turn off power” and Alexa would send the instruction to smartthings to turn off that switch.

However, that then became a reserved word for echo’s use. So if I said “Alexa, turn off power” echo turned itself off!

I ended up changing the name of the switch to “shut down.” That was all I had to do to get everything to work again.

So it may be the exact word choice is running into one at Echo is reserved words. There doesn’t seem to be a list of these anywhere, you just have to figure them out.

We do have a topic thread for echo naming quirks just to try to keep track of some of them:

1 Like

I should clarify that, yes, I’m using a virtual switch to run the routine…as I’m aware running a straight routine doesn’t work.

The switch name that suddenly started failing was Going To Bed.

When I try to switch it on through Echo, her lights just toggle blue and green and then there’s kind of a quiet ‘da-dunk’ tone. She says nothing.

When I went into the Alexa app, she appears to be hearing me just fine, she’s just not doing what I ask.

I changed the name of the virtual switch to Bedtime and she ran the operation just fine…so I guess maybe she doesn’t like the Going To Bed phrase anymore? Unfortunately, the ‘off’ commands that are associated with the routine are still not being sent through, but this seems to be a different issue that others are having. I sent through a support ticket on that part, so hopefully it gets addressed. Kind of hard to tell what’s actually wrong, especially given the ‘hiccup’ in the widspread system today…

1 Like

The toggle blue and green mean the Echo is trying to process an Echo command, so, yeah, " going" must be a new reserved word. I wish Amazon would publish a list of these. :sunglasses:

Oh well. I’m sure my wife is going to psyched about learning a new phrase. She hates it when I change stuff…

Thanks for the insight! The name change seems to be the fix…

1 Like