MiniMote doubling button press?

My Minimote starting acting odd last night. When I the button to turn lights on or off, it sends both commands. The lights will instantly come on, and then, they will go off. If you look at the activity logs, it shows that the light were sent the on command and then sent the off command, but I only pressed the button once. (If they are already on, the reverse happens.)

Anyone else seeing this? Everything seems to work fine through the mobile app, and all my scheduled and presence events are working fine. It’s just the Minimote that’s giving me weirdness.

(Oh, and I did power cycle my hub. It didn’t help.)

Any thoughts would be appreciated! Thanks!

2 Likes

We think this is related to another button device:

Support has been notified but they must be fighting bigger fires because we have not received a response.

2 Likes

Ok, I didn’t see that topic. Glad it’s not just me. I sent an e-mail to support as well, so hopefully, they’ll get something figured out.

It’s happening to me, too, on my Minimotes and Key Fob.

So sorry to hear that! Report it, so support can see the extent of the problem. :cold_sweat:

One of the SmartThings staff (the Device Lab Manager, no less!) reported he’s seeing the same thing, so hopefully Attention Will Be Paid. :wink:

1 Like

I will chime in as one with this problem as well but it doesn’t seem to affect all of my minimotes.

@Tyler, any idea when this will get fixed? I’m using minimote’s for wall switches in the living room and kitchen to control lights/‘Hello Home’ actions and one on the end table in the living room so this kinda sucks right now. Any information would be great.

Thanks

I have mine set up the exact same way so I’m feeling your pain. It’s unlikely we’ll see a solution tonight but our team has been able to reproduce the issue in our testing environment.

2 Likes

Please also check the simulated minimote, I encountered same problem with simulated minimote device
Cheers

1 Like

I’m having the same issues. I’ve been having it since yesterday, probably 9 PM on the 3rd PST. With multiple mini-motes, but not with my GE remotes that connect direct.

1 Like

You might want to try this. It worked with the 7 button scene controller:

It looks like that is specific to that device type.

They use the same app and both received the problem at the same time. However, I changed this in my minimote and it didn’t seem to fix it. I’m not sure I did it correct, however.

Anyone else try this fix?

I started having the same problem, However sometime mine will read the button getting pressed 3 times… Im hoping to find a fix for this soon.

@tyler is there any updates on this? Is this being fixed?

Have there been any updates with this? This is drive my family nuts.

@thrash99er

Try it again. Mine works now. Of course I changed line 149 to:

def buttonNumber = evt.jsonData.buttonNumber

Maybe this and something SmartThings did fixed it.

Still not working correctly for me (although somewhat better). Sirens and lights now work correctly but Sonos acts like there’s a “double tap”–when music is on it stops then immediately restarts; when music is off it starts correctly. Also, changing to modes seem a little wonky.

I’m going to redo all the buttons and see if that helps.

Still does not work for me either. Even after changing out the line 149.