MiniMote doubling button press?

I am still having problems as well; I was hoping this would be resolved before the weekend so I didn’t have to wait til next week. @Tyler, any news on this? FYI, it is still annoying.

I tried it again just now and it still works. The only other thing I did was a Z-Wave repair. However, the repair failed to complete and ended by restarting z-wave task. I’m going to try another repair tonight.

It is odd that some have the issue and others not.

I redid my buttons on the Minimote, keeping the same assignments. Then, when that didn’t work, I reassigned different actions to different buttons and my Sonos issues remain the same and I can still only change to 5 of my 6 modes but cannot change into Home mode.

Everything worked fine until a few days ago. I reported my problem to support and, on March 4th, they told me they were aware of the issuing and were investigation.

The two most critical issues for me (turning off a blaring alarm and turning on/off lights) have been fixed; the other two issues will hopefully be fixed soon.

I still have issues with minimote. It does double take:
From off: on-off-on
From on: off-on-off

1 Like

@beckwith, I mentioned this earlier but something weird I’m experiencing is I have 5 minimotes but not all of them are experiencing this issue. Two of the five do not seem to have this issue and of the three that do a double press of a button seems to work like a single press did a couple days ago. This has been annoying to say the least but my wife is particularly annoyed since it no longer fits her requirements of ‘it should just work’.

@April, @Ben, @Tyler, anyone know how long we will have to wait for a fix?

1 Like

I’m getting this symptom with some IFTTT actions also.

The issue appears to be in the Button Controller code that sends Push Notifications. It only appears to occur when Push Notifications are NOT enabled on a button (probably 98% of all use cases). Testing suggests that there are at least two workarounds that appear to restore normal button functionality (when Push Notifications are not a requirement for the solution).

PLEASE NOTE: The following steps worked for me, in my very simple use case that utilizes Aeon Minimotes as simple physical light switches for various Zigbee bulbs around the house. Not that it matters, but all my bulbs (GE/Link and Hue) are paired with my Phillips Hue Hub. ST is controlling them through Hue (Connect). My intention is to return to using the native ST Button Controller once its code is fixed by somebody much more capable than me.

OPTION 1. Modify all existing buttons to ENABLE Push Notification for every single button. (No thanks!)
OPTION 2. Temporarily comment out the offending code until a fix is found/released (Yes please!)

  • Create a new Button Controller SmartApp (from template) in the IDE
  • Comment out line 197 to prevent the sending of Push Notifications (even if enabled)
  • Save > Publish to Me
  • Delete your existing configured Button Controller SmartApp installation.
    • IN THE IDE: under My Devices > [Aeon Minimote Display Name] > In Use By SmartApps > Button Controller > DELETE
    • IN THE MOBILE APP:Dashboard > Convenience > Button Controller > Uninstall
  • Install a new Button Controller for your device using the modified SmartApp under SmartSetup > My Apps
  • Configure it as normal, noting that Push Notifications no longer function (regardless of their configured state in the UI).

I have to note again… this worked for my use case, your mileage may vary if you have more complex solutions.

In case you are interested… for a single button press configured to toggle a single light without any Options, Messages or Notifications configured, my logs before this workaround looked like:

7:42:20 PM: error java.lang.NullPointerException: Cannot invoke method toBoolean() on null object @ line 197
7:42:19 PM: debug toggle: [Living Room South (HUE1)] = [off]
7:42:19 PM: debug Found: [Living Room South (HUE1)] for lights_4_pushed
7:42:19 PM: debug executeHandlers: 4 - pushed
7:42:19 PM: debug Found 1 events in past 3 seconds
7:42:19 PM: debug button: {“buttonNumber”:4}, value: pushed
7:42:19 PM: debug buttonEvent: button = pushed ({“buttonNumber”:4})
7:42:19 PM: trace timeOk = true
7:42:19 PM: trace daysOk = true
7:42:19 PM: trace modeOk = true
7:42:19 PM: error java.lang.NullPointerException: Cannot invoke method toBoolean() on null object @ line 197
7:42:19 PM: debug toggle: [Living Room South (HUE1)] = [on]
7:42:19 PM: debug Found: [Living Room South (HUE1)] for lights_4_pushed
7:42:19 PM: debug executeHandlers: 4 - pushed
7:42:19 PM: debug Found 1 events in past 3 seconds
7:42:19 PM: debug button: {“buttonNumber”:4}, value: pushed
7:42:19 PM: debug buttonEvent: button = pushed ({“buttonNumber”:4})
7:42:19 PM: trace timeOk = true
7:42:19 PM: trace daysOk = true
7:42:19 PM: trace modeOk = true
7:42:18 PM: error java.lang.NullPointerException: Cannot invoke method toBoolean() on null object @ line 197
7:42:18 PM: debug toggle: [Living Room South (HUE1)] = [off]
7:42:18 PM: debug Found: [Living Room South (HUE1)] for lights_4_pushed
7:42:18 PM: debug executeHandlers: 4 - pushed
7:42:18 PM: debug Found 1 events in past 3 seconds
7:42:18 PM: debug button: {“buttonNumber”:4}, value: pushed
7:42:18 PM: debug buttonEvent: button = pushed ({“buttonNumber”:4})
7:42:18 PM: trace timeOk = true
7:42:18 PM: trace daysOk = true
7:42:18 PM: trace modeOk = true

As you can see, after the button push, everything executes as expected until it checks for the enabled/disabled on the Push Notifications setting… finds nothing (not sure what the boolean for a disabled state is here but it apparently gets nothing back) and throws an exception. Instead of breaking here the code appears to “try again”, clearly that fails again and after the 3rd try it breaks.

I tested the same button push with Push Notification enabled and that Bolean state appears to satisfy the code, the Notification is indeed sent and the light toggles without issue.

After the workaround is implemented, the very same single button press configured to toggle a single light without any Options, Messages or Notifications configured, produces logs that look like:

Success! No errors in the log, only a single state change on the light and it toggles as expected. I tried it with all 4 buttons using Push or Hold and with Push Notifications enabled or disabled in the SmartApp (even though they are temporarily disabled in code).

The only change I made to the Button Controller was to comment out line 197 as seen below:

Hope this helps somebody until the formal fix is released.


I’m not expert to create a workaround like this :tired_face:
hopefully Smartthings will solved this problem, and this will work correctly and simple like other devices

Having the same issue… hoping for a fix soon.

Yeah, I’m having the same thing. @beckwith I tried changing the line 149 and that didn’t work for me. I might try @robmattox work around thouhg as well.

Commenting out the notification line fixed it for me. I saw the error in the logs, but I was trying to figure out the problem. A workaround like this didn’t occur to me. It’s not the best option, but I don’t use notifications for the minimote at all, so I don’t care that much. Thanks!

Can someone tell me where I comment this out at please?


As you may know, the Button Controller SmartApp is included in the native mobile application under SmartSetup > More > Convenience > Button Controller. I’m not aware of any way to edit the code for SmartApps installed this way. However, we CAN edit the code for a brand new Button Controller SmartApp created in the IDE ( using the original Button Controller as a template. This is how I’m commenting out the offending code on line 197 and avoiding the multiple toggles on each button press.

  1. Login to the IDE
  2. Create a new Button Controller SmartApp from My SmartApps > New SmartApp > From Template > Button Controller > Create.
  3. This should drop you at the code tab of the new SmartApp. Scroll down and add a couple forward-slashes (//) in front of the code on line 197 as shown below:

  1. Click Save, then Publish > For Me

It may be possible to update the native Button Controller SmartApp with this new code but I’m not familiar with how that might be done so I just uninstalled all the Button Controller instances that I already had installed and re-installed the modified Button Controller that we changed in the IDE above. If there is an easier way then I appeal to the Community to offer suggestions.

  1. Open the SmartThings Mobile App and install the newly modified version of Button Controller from SmartSetup > More > My Apps > Button Controller.
  2. Configure as you normally would/did, noting that Push Notifications will not work even if you enable them in the UI.

This worked for me… hope it helps until SmartThings (et. al.) fixes the code in the native Button Controller.


I discovered the same issue with Line 197 when trying to figure out this issue, and posted a note about it in the “ZWN-SC7 Enerwave 7 Button Scene Controller” discussion. I can confirm that commenting this line out stops the unwanted multiple toggle and restores normal functionality.

Not having dug in to SmartApps programming too much, it seems like whatever object the find() method returns no longer contains a toBoolean() method?

Returned from a long trip around 07-Mar-2015 to find my minimote misbehaving like everyone else here is reporting. Basically appears that multiple events are sent, or perhaps single events are multiply processed.

This means that when I attempt to turn on a light that is controlled via a SmartPower outlet, the light turns on and immediately turns back off.

Oddly, I can turn my Hue on and off - the visuals on that are acting as though there are three presses. It goes on, off, on.

I have not set up the IDE nor do I wish to get into SmartThings hacking. I just want it to work. I spend all day coding and debugging flaky software, it’s not really my jam to be doing the same thing for my home automation system.

  • Mark
1 Like

I understand your frustration @snorkelman. We all consume our technology differently. The great thing about ST and the IoT revolution is that there are options to satisfy all types of consumers. It’s impossible to predefine all possible use cases and implementation scenarios for every household, however I think ST has done an amazing job of providing example SmartApps and guidance on granular customization. While it’s not for everyone, the code transparency, API access and availability of tools like the IDE are what makes ST so attractive to me. Having had the experience of X10 and more recently, Wink, the more complex decision trees possible with ST sets it apart. That said, if you are not so inclined, then I’m sure an ST developer or some enterprising member of the community will publish the fix to this minor little bug and ST will push it out to the native Button controller very soon. If you are comfortable waiting for that to happen then no worries. In the mean time, if you’ve got 5 minutes to spare and want to explore new possibilities, all my Minimotes are currently functional utilizing the quick workaround I mentioned earlier in this thread.

understand your frustration @snorkelman.

No, I’m not particularly frustrated, just trying to give a good report of what’s wrong, and would like to know when to expect a fix.

I do think there is a bit of a disconnect in expectations with SmartThings. I think it’s reasonable to assume that hardware sold by SmartThings should work. If there are bugs, they need to be fixed by SmartThings, not by the community throwing out patches.

Obviously a different story for things that are still in labs or not listed as supported, that makes total sense.

The Minimote is sold by SmartThings as a controller that can be used to turn lights on and off. When that functionality is broken, SmartThings needs to fix it.

If that expectation is incorrect, I purchased the wrong product. Given the marketing of SmartThings, I feel it is offered as a consumer-ready, fully supported product with an infrastructure that makes it hacker friendly. Those two things aren’t incompatible, but just because you have the latter, doesn’t mean you can neglect the former.

The fact that this thread is seven days old and there is no company response is a bad sign - it’s neglect.

  • Mark
1 Like

I agree with both of you @snorkelman and @robmattox.

Before I buy Smartthings, I thought ST is consumer ready product with bunch of developing and hacking option. I think it’s like 50:50.

This is example for ‘consumer-ready’ level. Smartthings must have great reliability of product that ST officially support. If, there’s something happen with this, ST must fix it.

At developing part with developers community, I really appreciate the community develop amazing thing that ST not officially support. Which is great, really great. We will have unlimited possibilities with our smart home system.

But, after a month using ST and join the community, I think Smartthing is a little bit at developing stages, not consumer ready platform.
There’s a lot of workaround with basic function.

I think the part of consumer-ready and developing platform is 30:70


1 Like

BUMP!.. Has anyone gotten anywhere with this? @beckwith I tried changing the code,but do i need to go to all of my minimotes, and delete the Button Controller and use my new Button Controller app?

The Mini-mote had made ST setup at my house fun for the rest of the family, but the double events is driving everyone nuts!!

@tyler What is the update, is this getting fixed anytime soon?

I hope to have an update today. Thanks all.