Meross has my head wrecked!

I’m at the end of my tether here and hoping for some pointers. I previously had Meross sockets in ST but removed them when they were no longer needed. I’ve now tried to re-add them and cannot get anything to be added to ST. Of the 4 that were previously there, I reset 2 hoping that might help things but no joy. I dont see anything in the device logs. I’m also still being hit by every device being moved to 1 room whenever I attempt this so really at the end of my sanity with this. Any pointers? They’re MSS310 sockets with the latest firmware.

You can get around this known bug by going to menu > settings > linked services > Meross and going through the setup there. Just click through the screens and it will add new devices to your existing integration and doesn’t move all your devices to a single room. It is definitely annoying when one has lots of devices.

I am not sure why the mss310 are not being discovered. First thought is to remove the integration from the path I pointed to above and set up the integration from + Smartapp again and see if that resolves it. If you haven’t tried removing the integration, you may want to try that option but again, sorry that you will experience the known bug again of all devices going into a single room when you go through that route.

1 Like

A little different to how you described it but the Linked Services seems to have been the solution. Through the menu screen, all I could do was remove the existing Meross integration. When I added the devices again, apart from everything yet again moving to the 1 room, I actually did manage to pull in the sockets this time around. Thanks for the help.

1 Like