Made ST app to Wake On Lan, but can't get Amazon Echo to use it

echo

#1

Hi all,

I’m a total noob at making our own apps in ST, but I followed the instructions at Is there a way to switch PC ON Wake On LAN using Smarthub? and I’ll be damned if in my ST app on my phone, it works great!

In My Home now there is a device “Dad’s Computer,” and when I press the “PUSH” button, my PC wakes up! Just brilliant. Love it.

However I’m struggling with what should be the easier part of this: using my Echo to trigger the device. I searched for new devices in my Alexa app, saw the new device “Dad’s Computer,” and it all looks fine now. But when I say “Alexa, turn on Dad’s Computer,” nothing happens.

I know I’m missing something simple, I’ve never had this problem before, so any advice would be greatly appreciated.

TIA.


(Tony) #2

Not sure if it will fix your problem, but this is what I would try (assuming that you can go into the Alexa app and manually activate the “Dad’s Computer” icon to turn it on and off in the Alexa apps’ Smart Home section; that verifies that the basic connection between Amazon and ST is working-- if that doesn’t work, these suggestions probably won’t either):

FIrst, the easiest thing: Try “Alexa turn Dads Computer On”. I’ve had this work when the usual word ordering does not (and then, weeks later, the usual word ordering starts working again). Have not a clue why aside from assuming its the usual tweaking going on in the cloud.

If that doesn’t work, it might be that Alexa just doesn’t like the name ‘Dad’s Computer’ for some reason (there seem to be many words which cannot be used for reasons that are not widely known). Try renaming it in the Alexa app to something else (you don’t have to change the name in ST). I have had these issues come and go; sometimes a named thing which worked fine for months suddenly stops working; I rename it to something else and it’s fine; example: for a while she wouldn’t respond to “Entertainment Center Light”, I renamed it to “Audio Cabinet” and it started working again. After a week or so renamed it back, and it has worked ever since.


#3

Thanks for the reply!

I’m still just really baffled though.

I tried renaming the device in my Alexa app, to many things, but it didn’t work. Pressing the button in my Alexa app also didn’t work. BUT, pressing the button in my ST app works great.

Look at these weird ST recent readings. I can see that Alexa is sending the request to ST, but it only works when I later press the button manually in ST.

I really appreciate the assist. This is driving me batty heh.


(Tony) #4

So if the Alexa app cannot make it function it is not a naming issue. Having not used the Wake On LAN with ST I’m not familiar with what actual device Alexa is trying to manipulate. I had assumed it was a virtual switch but I see the notation ‘momentary’. What device type is that? Hopefully someone else on the forum has experience with voice control of this type of device.