Amazon Echo - Link With SmartThings - Seeing [object Object] instead of actual ST device names


#1

I’ve been successfully linking and discovering SmartThings devices using my Amazon Alexa app since Amazon introduced support for ST. However this evening, after unlinking and then re-linking with ST in my Alexa app to pick up newly added ST devices, the ST device names are not showing up after selecting my location. Instead, all I see under “My Device List” is the following:
[object Object]
[object Object]
[object Object]
[object Object]
[object Object]

Anyone else running into this? I’ve tried closing and re-starting the Alexa app, logging out and back into ST, I even selected the [object Object] entries to see if the devices could still be discovered by Alexa, but no luck.

What’s interesting is that I separately launched IFTTT and re-connected to the SmartThings IFTTT Channel, and under “Allow IFTTT to control these things…”, I do see the SmartThings device names. So this leads me to believe the issue is specific to the handshaking with Alexa.

Any thoughts?


Problem with smartthings discovery by Echo
#2

Same problem is turning up in the Harmony integration. I suspect the LAN code, but who knows? Report it to support@smartthings.com

@slagle


(Kevin Tierney) #3

Based on what @JDRobertspointed out, it sounds like there’s an issue with the ST oath page. If the Alexa smart app is still installed, you can probably go into the ST app go to smartapps, find the echo app and add the devices there

And then you should be able to tell Alexa to discover devices


#4

Thanks @JDRoberts and @kevintierney, this was helpful. I’ve reported it, and I’ve added the devices via the Amazon Echo smartapp. But I’ll wait until morning to ask Alexa to discover said devices, seeing as the family is asleep and Alexa likes to announce how many devices she’s discovered :smile:


#5

@kevintierney, Alexa is not finding my ST devices when discovery is run, even though I selected all the [object Object] boxes when Linking. I’ll wait to hear from ST support.


(zraken) #6

Perfect timing!, just when I needed to set up my harmony hub remote. I submitted a ticket as well with a screengrab attached. Hope they fix it quickly.
I’m grateful that the existing integrations are not broken (have to remember to not touch anything that’s already working).


(mytaytay) #7

Same issue here with Object Object appearing when attempting to authorize Echo to view my Smartthings devices. Will email /open a ticket, as well.

I can add the devices using the Smartthings mobile app and discover them that way…thanks for that tip.


(joe) #8

just got an echo delivered today and have the same issue. hopefully it will be fixed soon.


(Lorne) #9

+1 for the same Object object issue. After the last fix, half my bulbs stopped responding with ST. I learned it again, but Echo couldn’t find it. Got the object BS


(Robert) #10

Same issues as above for me :frowning:

Tried doing a Live Chat, and email - no response yet.

Hoping for a fast fix, my devices weren’t even discovered through the SmartThings App.


(Robert) #11

New harmony hub, same object object and not finding devices in the Logitech app.


#12

Same issue here. The best thing about ST is this community!


#13

Just purchased ST an hour ago and things are broken…
Not enjoying this to much at the moment!

I hope you get this fixed fast!
Thanks


#14

Get used to instability :slight_smile: On a serious note though, and unrelated to this topic, install the app Rule Machine. Will make your life easy on ST


(Todd Whitehead) #15

Just got an echo. Not fun.

Sigh.

Smartthings is completely useless.

Cmon guys! This should be an urgent issue. 2 hour SLA.

How can this still be broken?

Where I work, this is the kind of problem where no one goes home until it is fixed.

Where is the pride of their job?

Get it together smart things!


(joe) #16

I just got my echo today so was a little bummed by this problem. but i did finally get my echo to work by authorizing it through that oauth page with one of those bogus devices selected. then i pulled up the smart app via the mobile app and authorized the devices from there. after that alexa could discover them. definitely not ideal but it did get me going with the echo tonight.


(Todd Whitehead) #17

@joe64, can you please provide more detailed instructions on what hounding?

I think there are a lot who would really appreciate it.

Thank you!


(Kevin Tierney) #18

What he is saying to do, is go through the setup process. When you get the [object Object] options, select one and authorize. This should install the app and allow you to go into your ST app go to your My Home ->smartapps, find the echo app and authorize additional devices


(Todd Whitehead) #19

That worked!

Thanks!


#20

Todd,

Goto the Alexa app in IOS or Android
Goto Settings
Goto Connected Home
Goto SmartThings - (Link to SmartThings)
Login to your SmartThings Account
Select your Hub
When you get the [Object object] check them all and save
Then
Goto the SmartThings App in IOS or Android
Goto My Home
Goto SmartApps
You should have the Amazon Echo as a SmartApp
Click the green plus sign and add the devices in (My device list) and save
Then
Goto the Alexa App and Sign out and back in again
Goto Settings
Goto Connected Home
Scroll to the bottom where (Devices Section) is and discover
It should find your devices even with this stupid error [Object object]

I tried many times over the last hour or so and only got it to work after logging out and the back in again.

I hope many of you find this helpful.

Regards,
Troy