Problem with smartthings discovery by Echo

Ok, so ST and Echo have been working fairly seamless up until yesterday when I messed something up.

One of my GE switches became unresponsive. I had to remove the device and have ST rediscover… problem solved with ST. Well then I tried to have Echo rediscover the device and it wouldnt. No biggy, it has happened before and I just unlink ST and relink it. That is when problems started.

When I go to relink, it asks what devices I want to authorize but the device names are all [object Object] (see picture attached to post)

No matter what I do I can not get it to display the device names when authorizing in Echo. ST is working fine and I see proper device names in ST app… Can anyone help me fix this?

Known problem, they are “working on it.” It has been 3 days though and it is like that for all things connecting to ST.
Not sure what’s going on with this thing…

1 Like

See the existing topic:

Hey guys,

Just wanted to let you know the OAuth device display bug has been resolved.

1 Like