Made a Water Leak Sensor

I have made two of these. One of mine shows 100% and one shows 50%. Neither of them have had any trips except for testing (no long open periods).

Sorry to rehash an old thread, but I just had to laugh at putting a water sensor in oblivious kid’s bathroom. My mind immediately went to 2AM, 1/2 asleep, bad aim and a siren going off . :dart:

1 Like

Ha! It’s under the sink in a vanity. I would hope (but you never know) that he’d notice his toilet leaking.

I was reading ZWave command reference document to understand why did Justin changed 0x71 from “3” to “1” for Alarm.
Reverted value for “0x71” from “1” to original value of “3” and it gave me below command detail for wet condition.
"NotificationReport(event: 254, eventParameter: [], eventParametersLength: 0, notificationStatus: 255, notificationType: 7, reserved61: 0, sequence: false, v1AlarmLevel: 255, v1AlarmType: 7, zensorNetSourceNodeId: 0)“
Did this " v1AlarmLevel” gave you idea of changing Alarm level to version 1 from 3? It seems only that value changed between dry and wet condition.
-Then you implemented AlarmReport to report sensor value change for wet/dry condition.
Great thinking Justin.
What gave you idea that third switch is un-used?
Unfortunately, it will force me to do more stuff after doing this first time :smile:

opps and 10

Hey Justin I was wondering if it is ok to use your code for something slightly different. I need a device to tell me when the water level is too low. I have a homemade automatic water with splash catch for my pets and just recently my ADHD family members forgot to refill it. It blew out the pump so I am thinking about making a sensor to tell me the water is too low. I think I can repurpose you code for this if that is okay with you.

1 Like

Of course!! Sorry for late reply…

Based upon THIS post, I bought several Monoprice z-wave door and window sensors.

After successfully pairing the Monoprice sensor to ST, I went to the IDE and created a new device handler. I pasted in the Gethub code that was provided in the above linked post.

Then I went to “My Devices” and found the Monoprice sensor, which I renamed. I also changed the “Type” to “Z-Wave Water Sensor” from the drop-down menu.

The Monoprice was then opened up, and I connected one wire to each of the empty screw-down terminals.

My phone app shows the renamed device, and when I put the ends of the two wires I’ve added into water, the red light on the front of the Monoprice lights up. However, the app still shows it as being “dry”. The red light on the Monoprice remains lit despite being out of water, and will not turn off (black button reset/battery removal/etc). As a side-note, the app does report battery status percentage.

Any help would be greatly appreciated.


The best thing would be to ask your question in the original thread. That’s where people will be able to help you.

I had considered that, however it’s a rather old thread, and I didn’t want to resurrect the dead (so to speak). Sorry, I haven’t quite picked up on the local etiquette.

Moderators: Should you deem it appropriate, please feel free to move my post.

I just figured out that if I put the cover on the back of the Monoprice, the red light turns off. However, when the wires I installed make contact with water, ST still reports it as being dry.

No problem, every forum works a little differently. The discourse software, which this forum uses, will send a Notification to the original thread author as well as any individual member that you reply to in a thread. So even when it’s an old thread, it will get the attention of the people who are most likely to be able to help. :sunglasses: Also it helps keep the forums organized for future searches.

Thanks! I didn’t know about the notifications. A cursory check of a few members profiles from that thread indicated that they had not been actively on this site for quite some time.

You seem to be a man of knowledge around here. What say you to my quandary?

What happens when you place the magnet next to the sensor and use it the “normal” way? Does the sensor then say “Wet”? What about shorting the wires - I’m guessing that doesn’t work, right?

I suspect you need to exclude the device and re-pair it. You could also just have a bad sensor - have you tried another? FWIW, I have three of the same sensors used as water sensors (don’t recall the DH I use, but it might be the same one) and have not had any issues. I’ll periodically take a screwdriver and put it across the wires to short them to ensure they still work fine.

First, I really appreciate you chiming in. I was afraid that there was no one around who had made this conversion.

Nothing. The app shows “Dry”. I’ve tried shorting the wires by making manual contact, sticking them in my mouth, putting them directly into water, in between a wet towel…same result.

I’ve excluded it once, and I will try it again when I get home from work tonight. I have two more sensors, and I will try another one to see what happens.

I tried re-pairing and ended up with the same result. So, I tried using a new sensor. Again, same result.

Neither are reporting “Wet”…:cry:

Would the next step be to remove both sensor and the DH; then reinstall the DH and sensors?

My initial fear was that the DH is no longer valid, but you have working sensors…

Are you using the Monoprice Zwave or Zwave Plus sensors? I’m using the older Zwave sensors and if you’re using the newer Zwave Plus sensors, maybe the DH needs an update?

Also maybe try using an alternate DH from the IDE and see if basic open/close functionality reports correctly.

The box says: “PID:10795 Z-Wave door and window sensor”, which according to their web site is not the Zwave Plus. Good thought though.

Out of curiosity, using a volt meter, I checked the continuity between the two wires, and then between the screws that hold the wires to the circuit board. No continuity.

Have you tried repasting the code from github?