Lutron lighting integration

Hi - my SmartThings system has developed a strange problem in the past few weeks and I need some help troubleshooting it. I have ST integrated with a Lutron hub and it has worked well for a year or so. The problem that has developed is that ST no longer received switch status from Lutron.

I can control all the lights from the wall switches and similarly I can control them from the new ST app dashboard. However if I turn a light on using a wall switch, the ‘on’ status is not reflected in ST. The light still shows as ‘off’ in the ST app.

I have rebooted the Lutron and ST V2 hub but the problem persists. Has anyone else seen this behavior?

Not sure if this will be of any help or not but I have seen it briefly with the set up like yours. Sometime I have had to close the new app completely and reopen it for it to show correct status of some of my switches. I also have went to re-add the lutron account as if bringing in more devices. Hopefully someone has had the problem and know more on how to correct it will chime in.

Other people have reported it in the last few weeks and it is being discussed in a couple of active threads in the forum. See those. (The topic title is a clickable link)

Automation Issues with Lutron Caseta Switches

Yep, the way to resolve the status not updating in the ST app for lutron caseta devices is to remove the integration in menu > settings > linked services.

Take screenshots of any automations/scenes before removing as any automation and/or scene that contains lutron caseta devices will be removed.

Hope this helps. Further details in the thread @JDRoberts linked to

1 Like

That worked. I removed the Lutron integration and added it back in, but some devices were duplicated. I deleted these devices in the ST IDE and then added them back in using the App.

Now everything works as it did last month. A time consuming hiccup. I hope we don’t have more of these.

Paul

1 Like