Caséta Lutron and SmartThings

Hello All,

I am in the need of some help with my Caséta Lutron devices when I press any of their switche buttons and they turn on but they don’t register in the smartthings app as on or off but if I turn them on using Amazon Alexa, they register.

So any of my automation are not working because my hub is not recognizing them being on/off. I have already tried to remove the integration and add it back and removed switches from the both hubs, Lutron hub and smartthings up and added everything back in. I have also deleted the connections between both hubs and added it back in. It didn’t fix it.

They are not working so the communication in the cloud is not happening, but when I do use Amazon Alexa to turn them on, everything else is working fine they register in the app the automations run OK.
I just need some help figuring out what the issue there is?

Is Alexa turning the switch on/off via SmartThings or via Lutron?

Did This used to work and then it stopped working?

The reason I ask is that Lutron put out an update to their own app last month, and it caused several integrations to stop working.

At our house, we fixed it by first unplugging the lutron smartbridge for two minutes, plugging it back in, then Found we were not signed into the Lutron Caseta app anymore.

We signed into the app, and our smartbridge showed as not connected.

We rediscovered the SmartBridge in the Lutron Caseta app and once it showed up there again all the other integration started working.

So that’s the first thing I would try if you haven’t already. :thinking:

1 Like

Via smartThings

Power down your Lutron hub as @JDRoberts mentuined and reboot your router

Just reboot it the router and Lutron didn’t solve it.

Did you go into the Lutron app? (not the smartthings app) and verify that your smartbridge is connected there? That was the critical step at our house. After the most recent app update, the Lutron app had disconnected from the SmartBridge.

I don’t think the Lutron SmartBridge shows up as a device in the Lutron app. As long as you can open the app and control the devices there, I think the SmartBridge was automatically added.

Yes, I can. But the automation don’t work. ST hub still didn’t recognize when I turn lights on or off using the physical switch

I’m sure that’s very frustrating. :disappointed_relieved:

Lutron maintains that integration, so I would suggest getting in touch with their support.

The support options are at the very bottom of the following page:

I just submitted a support ticket.

1 Like

Clear something up for me … if you physically turn on/off at a lutron caseta switch… does the app reflect the change or is it the automation that is not working or both?

No, it doesn’t. The only way I can get to reflect the change is use Amazon Alexa or the app itself

and you powered down the Lutron bridge for a minute? rebooted your router?

There is an old thread around here about this very topic. The status of the lights is VERY slow to update. Slow like minutes or hours, sometimes pretty quick.

I gave up doing any automation that relies on the actual status of Lutron lights. If I need it then I made a virtual switch that I turn on and off in tandem with the real switch, then I check the status of the virtual switch. That only works in some scenarios but it’s all I could come up with.

Other than this really annoying problem, they work fine.

1 Like

Yes. I rebooted everything

how long have you had your ST hub? have you ever gone into IDE before?

About a year or so.

Yea, I am comfortable with IDE.

1 Like

Please keep posting if you all come up with a solution. I have been debating between habitat and smartyinga for a year and just pulled the trigger on smart things. I was hoping to start adding lutron next…