Lowe's Iris Sensors (New CentraLite models)

The Iris Care Pendant came in on Friday and I had some time to play around with it. I created a separate topic over here:

2 Likes

I had them turning on/off lights via the smart lighting app.

They were working, and poof they were gone.

I just posted a device type for the Smart Fob:


Let me know if there are any issues!

6 Likes

I saw, I will try it tonight after the kid goes to sleep. Thank you!

Hi. Somewhat of a new user here. Bought a couple of the new iris motion sensors but could not get the temperature to update automatically. I have to refresh all the time to get a new reading. The contact sensors update themselves though. Any help? Thanks

My motion sensors update automatically every hour, if and only if there has been a temp change. I am using the SmartSense Motion/Temp Sensor. You might try excluding and then including the sensor again.

I’m having the same issue.

@mitchp have you been able to look into this problem? I know last time it was brough up you didn’t have a motion detector to be able to test it out.

I haven’t picked up one of the motion sensors yet. This is almost certainly a case of a configuration command being missed during join, assuming the sensor isn’t faulty. There’s nothing odd in the logs?

nothing odd, it just only updated the temp when you hit refresh.

Okay… I give up. I need help.
I just got back (and by just - I mean three hours ago) from lowes. Where I bought the following:

2x http://www.lowes.com/pd_690405-41277-3450-L_1z0vihb__?productId=999925322&pl=1&Ntt=iris
2x http://www.lowes.com/pd_505521-347-ZCOMBO_1z0vihb__?productId=4780109&pl=1&Ntt=iris
1xhttp://www.lowes.com/pd_753204-41277-9404-L_1z0vihb__?productId=999929892&pl=1&Ntt=iris

And now I feel like the biggest goofball of all time. The two Z-Wave smoke alarms paired fine.

I cannot get any of the ZigBee stuff to connect. I’ve tried a motion sensor, key fob, and contact sensor. All of witch just give me a blinking blue light and never show up when I click + Connect New Device for my v1 hub. Motion does give the occasional green blinking light.

I’ve added the keyfob and motion device types mentioned above.

Because these devices are not yet officially supported by smart things, you’ll need custom device types for each one of the Zigbee devices.

You may already know how to do that, but if not take a look at the following FAQ first:

After that, if it’s something you want to go ahead with, you have to find a topic for each device that has the link to the new device type for it. I believe most are in the “community created device type” section of the forum. You can then ask questions about any individual device and its thread.

https://community.smartthings.com/c/projects-stories/community-created-device-types

JD,

There are several device types listed above, including the link for the fob device type, and the iris motion/temp device. (mitchpond : Iris Smart Fob) (smartthings : Iris Motion/Temp Sensor) I’ve set both of these up in the IDE before attempting to pair the devices via the app. Usually when Ive used a few custom device types in the past, there has not been anything preventing them from being paired with the “connect a device feature”. Usually they pair fine, and then I go into the IDE and change the device types from some generic zwave to the proper device type.

Is that not the case with these? If so, how do I go about getting them to pair to my hub?

Looks like the pairing process can be difficult on these. See posts 88, 92, and 310 above. (Tap on the timestamp to see the post number.)

I just bought another motion sensor this evening and problems with it pairing. Follow post 92 above and should work. That worked for me.

Try to connect. Let it spin for a while then if it doesn’t connect, close Smartthings app completely, then restart and go back in to connect and you will likely see the device there as not yet configured.

BTW, We see the same pairing issue with some other battery-powered Zigbee devices, like the smartenIT 3 toggle. It appears to be a timing thing. The device is asleep when the configure comes by the first time, it misses it, and then when it does wake up it’s expecting a response from SmartThings that doesn’t always come in time and so the pairing happens but the configure doesn’t.

The fix is the same, force close the app, the device will be there not configured, configure it through the IDE.

Okay, so I grabbed a sensor I hadnt touched yet and followed the instructions in post 92 to a tee.

How long is “a while” 30 Seconds? 2 Min? 5 Min? I tried three times…

Click Connect.
Insert Battery.
Wait.
Force Close
Re-Open

No “non configured device”. Like I’ve said before I never see the device show up on the “I’m looking for your new Things…” page.

One thing I did see was when I was attempting to pair the device other events in my house fail. I have a light set to turn on when the door opens, and it fails while I’m trying to pair (during the 5 min test). Is this normal? These are my first Zigbee devices… so maybe there is problem with my hub?

Searching for a new thing probably keeps other network traffic from being processed

While your hub is in pairing mode it probably does ignore other network traffic, so other devices " failing" in itself wouldn’t concern me if it’s just the “searching for a new thing” time interval.

Reset before trying again

Did you reset the device before trying to pair again? You might’ve gotten a partial pairing that failed and you need to reset to factory settings before trying again. Typically on a zigbee device that means removing the batteries and waiting at least five seconds. Then pushing a button somewhere on the device and holding that button in while reinserting the batteries and continuing to hold the button until the light flashes. But the exact method can vary by device, I’m not sure just what it is for these. There should be reset instructions in the user guide.

How long to search

As far as how long, I typically wait four minutes for Zigbee pairing. The Phillips hue bridge suggests waiting “up to three minutes,” so I think that’s a likely residential zigbee scenario.

When all else fails

It could just be a bad device. It happens. I know some of the posters up thread have said some of their sensors were bad and had to be returned to the store. I know that’s frustrating.

1 Like

Tried that but still doesn’t work. Not sure what I’m doing wrong. Have two motion sensors and both acting this way. Thanks for the response

Did you look for it in the IDE? it should be named “thing”. Go edit and change device type. It only take the motion sensor about 5 to ten seconds to pair, watch the led on the motion sensor to stop flashing.

I’ve lost track of how many Iris motion sensors I’ve bought (10+), but all have been successfully added and working perfectly. This is what I do:

EDIT: I updated/added steps starting at #11.

  1. In the phone app:
  2. “Connect New Device”
  3. Pull the plastic battery tab (or insert battery)
  4. Wait until it’s “found”, and then tap the back arrow (< SmartThings) after just a few seconds. Takes you back to Marketplace.
  5. Wait (a few seconds, but your mileage may vary) for the “Not Yet Configured” entry and tap on it.
  6. Do what ever I need to name it and place it in a Room. Walk through remaining steps. Done with phone app. Right now it’s just a “Thing”
  7. In the IDE:
  8. Go to the Room where the new device was added, and select it and click on Edit. Remember, it’s a “Thing”.
  9. Change Name* to “SmartSense Motion Sensor” and Type* to “SmartSense Motion Sensor” and click on Update.
  10. Done with the IDE at the moment.
  11. On the device and in the phone app: (UPDATED)
    11.1 Repeat step 1 and 2
  12. Remove the battery
  13. Press and HOLD down the small button on the side of the device. You’ll feel a slight click.
  14. Reinsert the battery, and only release the button when the light turns blue. It will flash blue and then green.
  15. Done with the device.
    15.1 Repeat step 4, except this time you won’t see any message for it being “found”, just go back to the Marketplace.
  16. In the IDE again:
  17. Go to the device’s event log.
  18. You’ll first see the CONFIGURE command sent, and then battery, temperature, and motion events in no particular order.
  19. In the phone app again:
  20. Go to the device and hit Refresh". You’ll see that in the event log as well

Everything should be working as expected after all that. Seems like a lot, but not really considering no formal device type exists yet from ST. I did the same thing for the Iris open/close contact sensors.

16 Likes