Lowe's Iris Sensors (New CentraLite models)

Thank You! Just got my SmartThings hub today and bought a lot of the Lowe’s sensors since they are such a great bargain. Was trying to find some instructions on how to set them up. Your post was extremely helpful!

@johnconstantelo thank you very much for posting these instructions. I had tried to get the SmartSense motion device type to work before without success so ended up using a custom device type that was posted above.

I have been trying to get everything running locally and it bothered me that this motion was not and with your help it now is along with the Smart Lights app. Thanks again.


I followed these instructions for the contact sensor (v1 hub) and it’s not working. Any tips from someone who has successfully paired these two?

1 Like

Looks like some have gotten it to pair by using custom device type. I will give it a go when I get back home.

UPDATE: I successfully paired by changing device type to SmartSense Contact Sensor but it would not recognize open/close state.

I removed and started over using the device type from the top of this post and it successfully paired in 5 seconds.

Cheers. Thanks to all who contributed to this thread.


So after returning the “kit” and picking up a single motion sensor, I was able to get it to pair with smart things. Its interesting that the two devices had different brand batteries. The new sensor came with a yellow banded battery compared to the solid silver one of the old. Maybe the battery was too low.

So ive gotten it paired and changed the device type in IDE, but cant seem to get the config command sent.

Steps 12-15 involve resetting the device.
I’ve tried this step a few times and I just have a flashing blue light and it does not send the config command.


I picked up a motion sensor and it is not working at all. I’ve tried @lonestarbuzz’s instructions and @johnconstantelo’s instructions. No joy.

Is it perhaps possible, that not all of the Iris sensors are the same? Some work and some don’t and it depends on which batch your sensor came from?


@Todd_Whitehead, you could have a bad sensor. Even though it’s not common, these are new and there could be a batch that are bad. I know @Mike_Maxwell had one or two that just wouldn’t pair, so he exchanged them. I just got home from being out all day, and picked up another motion sensor at Lowes.

EDIT: @Todd_Whitehead, please look again at post above. I just paired the motion sensor I just got, and ran into the same thing you did. I added a step to “Connect New Device” again for safe measures, and it worked and sent the CONFIGURE command. For some reason I didn’t believe that second connect new device step was needed, but apparently it was.

It have to look like this: ( different look = wrong sensor)

  1. Install device type.

  2. Pair device (Mobille app + pull paper strip from battery a reinsert battery)

  3. check if is everything set as should be here:

  4. use it as any other device in smart apps

1 Like

@plantucha You’re making the assumption that someone wants to create their own device type like @mitchp’s instead of using ST’s default that also works (that the custom ones are based off of ST’s). Some won’t want to do that.

Hi Allen, would you mind trying again? I just picked up another motion sensor and ran into the same problem as you did (and @Todd_Whitehead). I added a couple steps to repeat the connect new device steps, and once I did that the motion sensor received the CONFIGURE command and started working as expected.

But also some may want to try that, since build-in function doesn’t work for them.

So, I’m able to get the configure command sent, Ive tried twice with the SmartSense Motion Sensor device type, and once with the custom Iris Motion/Temp Sensor device type above. It seems to send the config, but never temp battery or motion events.

Take the thing back and get another one. I had two go bad. One just would not pair no matter what, and the other went stupid after 2 weeks of use.
I have 10 of these now and they have been fine.

1 Like

@raggedrebel92, I’d say you’ve got a device that just won’t behave. You can try removing and putting back the battery, but from the looks of that log file, I’d ask for a replacement device.

1 Like

This worked for me! (Except I chose motion and temp for the device type. The extra steps @johnconstantelo added made the difference. It wasn’t working until I did that. Doing that worked great.

After the failed attempts, before trying again, I removed the battery and then from the ST app, I deleted the failed device and then started from the top of his instructions, except where he says pull the tab, I put the battery back in.

Thanks, John! This is definitely a working set of instructions!!!



Well I’ll be damned. I finally got the thing working. I grabbed a set of new batteries and it instantly identified as a thing.

However, changing the device type didn’t do anything, still sent the single config and stopped. So I deleted the device, and started over. This time it discovered a “Iris Motion/Temp” (The custom device type).

I waited, still no temp or battery commands. So I did one more reset and boom. Battery and Temp came first, then motion!

Whoo! :stuck_out_tongue: I need a drink.


Went into the Lowes around here in San Antonio, TX, the ‘Iris’ walls were practically bare… How many of you guys live in San Antonio :smile:

There were a few contact sensors though @ $22.99 I believe, are you guys getting them cheaper? I’ve lost track of all the deals going on…

Holy cow, what a PITA that was for you. Glad you’re working finally.

1 Like

If the new Iris door sensors are now working with ST how can I tell the new one from the old?

They come in a purple box instead of a plastic blister package.