Lots of "Things" in new app (STSC)

Usually use the classic app, but have been playing with the new STSC app recently and noticed that it shows 18 "Thing"s that I can’t delete, open, edit, or modify in any way. If I click on them from the device list nothing happens. If I click on them from the room they were assigned to I get an error message that reads “Can’t connect to device. Check device and try again.”

It also shows a hub called “Virtual Hub”, which I can open and have options to edit, but an attempt to delete it failed with a generic error message. There was also a switch named “Virtual Switch” that I’m fairly sure I didn’t create (I’m pretty good about assigning a sensible name to any virtual devices I create), but was able to delete that. None of these "Thing"s or the virtual hub or virtual switch show up in the classic app or in any of the IDE menus.

Any ideas where all these phantom devices came from or how I can get rid of them?

Email support and ave them runs a Sync job

2 Likes

Thanks, contacted them yesterday but thought I’d ask here too. ST isn’t always super responsive to support tickets IME.

Consumer support is not monitoring this community in any substantive way. Your best bet is always going to be via official support channels.

1 Like

Thanks, I’m aware that support doesn’t really monitor this community, and appreciate the ST staff like yourself that does contribute here. I was just hoping that the community might have a solution that didn’t involve intervention from ST support, like they did when I encountered issues created during my account migration from SmartThings to Samsung.

As an update, ST support did respond a few days ago and said they were looking into it. Last night I noticed some changes in the new app. All the extraneous “Things” were gone, but the hub was listed as being offline, and all but one of my rooms were gone. The one remaining room had two devices left in it, but the remaining devices from that room as well as from all my other rooms had been moved to the “No Room Assigned” category. Virtual hub was still there, and also shows as being offline.

All ~75 devices in the no room assigned show as offline, and I can’t control or access them in any way using the new app. Using the classic app I can access and control all of my devices as usual. As a troubleshooting measure I tried adding a couple of new devices (Ikea Tradfri socket and button) using the new app, and I wasn’t able to. I then tried adding them with the classic app and they paired just fine. I then opened the new app, and the newly paired devices were there, show as being online, and I’m able to control them from the new app without issue.

Got an email from support at 3am telling me they’d “cleaned things up on your account”, and that I might need to re add devices to my rooms.

I’m really hoping I don’t need to delete and re-add 75 devices and rebuild all of my webCoRE pistons and other automations to get this resolved. I really would have preferred a bunch of extraneous virtual devices I could hide somewhere over having to rebuild everything from scratch.

Update:

I noticed a couple of contact sensors, a vibration sensor, and a couple of zigbee bulbs come online Friday afternoon. Then on Sat afternoon the hub started correctly showing as being online, and the vast majority of my devices also showed up as online and controllable. The only things that still show up as offline are virtual devices, and things with custom DTH’s that never worked with the new app anyway.

I remembered needing to switch the DTH’s of my virtual devices a while back to get control of them in the new app, so I tried switching DTH’s, saving, switching again, and saving, hoping that would get them back. No such luck however. So I tried making a new virtual switch, and it works just fine in the new app. I think I’ll just delete and recreate all of my virtual devices and rebuild the automations that use them. Not a small task, but vastly better than deleting and recreating everything from scratch.

Support was much more responsive than my previous interactions, and more or less got things working again quickly. Thanks ST support!

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.