Lost connection to some of my wemo's


(Dan) #1

A few days ago 90% of my 12 wemo light switches stopped responding in ST. IFTTT and WEMO iOS app still talk to the switches fine. I’ve tried rebooting the hub. Next I’m going to try uninstalling one of the switches from ST and re-adding it. Did some software update happen last week that may have caused this?


(Matt) #2

Every once in awhile my Wemo’s stop talking to my wireless ap. Generally if I reboot the AP all is well. You may want to try that. Also maybe turning the breaker off and on that your Wemo is connected to. See if they sync back up properly.


(Terrell Mackall) #3

Any updates on this? The last time I had it happen I had to remove all the wemo switches and smartapps associated with them and then reconfigure them all. It was a real hassle. Luckily I only have 3 and my setup isn’t that complicated yet. Hoping there is an easier method as I just lost connection with the same switch again. Still works fine through the native wemo app.


(Matt) #4

have you tried emailing support? They may able to provide a better answer as to why it’s happening and maybe there is something that needs fixed? I have only had the one issue so far. I don’t plan to use WeMo devices long term, but for now they get the job done.


(LimboMan) #5

Same situation here – removing and adding again my devices was a real pain, but the only solution I had at the time.


(Dan) #6

I had to remove all applications associated with each problematic wemo switch. Then remove and re-add the switches and re-add all applications (PITA). They worked fine again for a couple weeks and now it’s happening again. This is not a wifi issue since the wemo app and IFTTT can still function fine with the same switches.


(LimboMan) #7

The removal and re-add was indeed a real pain, as there is no easy way to simply “remove”. if the device was associated with a smartapp, you’d have to go in each individually to remove and then re-associate everything after it has been re-added. Same situation here, where WeMo and IFTTT remains working, just lost association with ST. Trying to find out if we can assign fixed IP for WeMo devices… that would probably fix our problem (Though WeMo and IFTTT are able to find the devices just fine)


(Dan) #8

I have reserved IP’s through my DHCP server for each Wemo (preventing the ip’s from changing on the devices)


#9

Definitely email us at support@smartthings.com if you haven’t already.

Another common fix is to open up the WeMo (Connect) SmartApp and click each device option to help it rediscover the devices.


(Kermee) #10

This just happened to me also after working fine for about two weeks. I had to uninstall and reinstall everything. Logging into graph.api.smartthings.com and looking at the WeMo under ‘Devices’, it will show the WeMo device as ‘INACTIVE’ even though the IP hasn’t changed and the WiFi working perfectly as I can ping the WeMo device just fine, IFTTT is able to control it, etc.

Also, a new WeMo firmware for my ‘Light Switch’ just came out a few days ago. Not sure if that had any affect on it.

Cheers,
Kermee


(LimboMan) #11

Currently my devices work only intermittently (with ST) which makes for a real pain to troubleshoot. IFTTT and native WeMo app continues to function as expected. I know all my WeMo devices got an update recently – maybe that may have been the culprit. Can anyone else confirm that new firmware got pushed to the WeMos?


(LimboMan) #12

Just checked-- interesting find: my one remaining WeMo device that still listens to ST is on a “WW” firmware vs the “US” firmware. I’ve got two on my list but am still waiting to see if anyone can make my Insight Switch work on ST. So my only remaining working device is my Wall Switch (“Front Door”)

Can someone else check to see if you have a similar finding? What firmware are your working devices on?


(Dan) #13

@LimboMan, my working and non working switches are both on WW. It’s that magical time again to do the whole delete and add. I’m tempted to have IFTTT handle the switches and relay commands to ST. Only problem is IFTTT has a longer delay.


(Terrell Mackall) #14

Thanks for the replies. I’ll be sure to get in touch with them the next time it happens. Good to know (I guess) I’m not the only one having this issue, the joys of living on the leading edge of technology. Sorry for the late reply, signed up with google account and I don’t use my gmail… and of course when I tried to switch to my yahoo email, it said it was already in use lol.


(Alex Christensen) #15

I think I might be on to something with the WeMo devices disconnecting. Mine seem to stop responding to ST when I have to reboot my Wi-Fi router. It used to also disrupt my Hue integration, but I made a DHCP reservation for the Hue hub and that has now been perfect. I’d rather not have to go through and do the same for all 8 WeMo devices I own. It seems that ST is locking on to the IP address of the LAN devices rather than the MAC or something else unique, and does not update it’s table when they IP changes. @Ben @urman any ideas? Thanks.


(Dan) #16

@bazfum I have all my memo ip’s reserved. They don’t change but the problem continues to occur.


(Michael Sammon) #17

This fix worked perfectly. All you have to do is open the ST app. Sit there for a moment like it would normally do to discover items then close. All is well. Thank you.


(Jon Christensen) #18

This worked for me. I had to uncheck all lights in the wemo smartapp, click save/done, wait a few seconds, then add them back in. No reinstalling required.


(Bill Kearney) #19

I had one switch that was still on 9399 and no amount of rebooting, power cycling or using a different Android device (app removed and reinstaled) seemed to be able to get that one to trigger a firmware update. I used an iPad, freshly updated and with a fresh install of the WeMo app. It was only then that the last switch got the firmware update.

I’ve likewise configured my router’s DHCP tables to give the WeMo addresses static leases. Thus far (two days) the ST client still sees them.

Personally, I think using WiFi for this is a bad plan, as it’s too easily disrupted/misconfigured. But I’ve yet to find another plug-in module that also has a local control switch on it. I find it handy to have a button to toggle it on/off in the places where I want the control. Anyone seen a z-wave plug-in module that has local control like that?


(Bill Allemon) #20

The latest Samsung ST outlet has an indicator light and override button on the face, which I like. I have both WeMo and ST outlets. I’m preferring the ST outlets because they also report power usage, although their max connected current rating is slightly lower than the WeMo devices. I’m currently using an ST outlet to control a room heater without issues.