Location Modes Not Working (October 2021)

Does anyone see Setting Home to ${location_mode} as requested?

Yesterday I noticed things weren’t trigger. After a little digging I quickly noticed that location modes weren’t actually firing. Digging into the logs I saw this template.

I haven’t changed anything in weeks… Anyone else having this issue?

1 Like

It appears to mostly be in the Groovy SmartApps. Like WebCore, I can see what the $locationMode is, but the Triggers don’t fire. The same goes for any other Groovy apps. Is this their not so subtle way to push us off of those to their automations and rules api?

Same issue with location mode not changing here. I have a simple good morning scene that changes my location mode to “home” and a good night scene that changes the mode to “night”. Running these scenes has no effect on location mode but can control other things (e.g., switches). Only way to change is manually via actiontiles.

This is all within the SmartThings app so no groovy, webcore pistons, etc. involved.

Worked fine before but randomly stopped working 3-4 days ago.

1 Like

This had happened a month or two back for me and then resolved after a couple of days. I noticed it with Webcore, so I posted on their forum and others had noted the same. Never knew why it happened, but I wasn’t alone. It is now happening to me again too.

Same issue for me also. I’ve tried using the $locationMode variable directly in WebCoRE and that didn’t work either.

Same issue here for several days now, and this is affecting any SmartApp (WebCore, ActionTiles, BlueIris, etc…) that is using LocationMode.
I’ve migrated the mode change logic to HA (Home Assistant) and I’m calling SmartThings Scenes from HA to update ST.

How are you getting the location mode into HA?

Hey Steve, several months back I’ve created the same logic for location modes in HA (Home Assistant) and both systems (HA and ST) have they own Modes and Automations. I’ve decided this way so if I had an issue with one System it would affect the other.
I’m just using HA Automations to replace WebCore and calling ST Scenes to change the modes in ST.

1 Like

Look! Someone at Samsung fixed their platform! :joy:

1 Like

Looks like it is working again for me as well!

yess for me too. thanks

Likewise - the mode change is being recognized by Smart Lighting. Support claims that my logs submitted last week show that the automation was being triggered but clearly there were issues as I know they weren’t.

I’m having this problem at present. Does anyone else have this problem, now?

I am having the same issue. Started yesterday.

error groovy.lang.MissingMethodException: No signature of method: physicalgraph.location.LocationService.updateMode() is applicable for argument types: (physicalgraph.app.LocationWrapper, java.lang.String, java.util.LinkedHashMap) values: [Hub, xxxxxxxxxxxxxx, [:]]
Possible solutions: updateMode(physicalgraph.app.LocationWrapper, physicalgraph.device.cache.ModeDTO, java.util.Map), updateMode(physicalgraph.location.Location, java.lang.String, java.util.Map), updateMode(physicalgraph.device.cache.LocationDTO, physicalgraph.device.cache.ModeDTO, java.util.Map) @line 142 (changeDay)

I’m having the same issue. For about 18 hours now.

Same issue, but SmartThings status is “All Systems Operational”.

Location mode changes via WebCoRE started failing for me yesterday. I see this in the log:

Error executing virtual command .setLocationMode: (2ms) groovy.lang.MissingMethodException: No signature of method: physicalgraph.location.LocationService.updateMode() is applicable for argument types: (physicalgraph.device.cache.LocationDTO, java.lang.String, java.util.LinkedHashMap) values: [Home V3, c7c8389f-2a7f-4e45-9fa2-e24acae51a0a, [:]] Possible solutions: updateMode(physicalgraph.device.cache.LocationDTO, physicalgraph.device.cache.ModeDTO, java.util.Map), updateMode(physicalgraph.location.Location, java.lang.String, java.util.Map), updateMode(physicalgraph.app.LocationWrapper, physicalgraph.device.cache.ModeDTO, java.util.Map)

looks like its been resolved.

I had the same issue today and few other times in the last 2-3 weeks. I seems to be working at the moment but clearly this mechanism isn’t as reliable as it should be. I am just using the ST automation to call a scene that changes the mode.
Is there a better way to control location mode? Anything simpler and 100% reliable?