Smart Lighting Location Mode Automations Not Running (Oct 2021)

Just checking to see whether others are experiencing issues with Smart Lighting automations. I have a very simple Smart Ligthing automation which triggers a scene “All Lights Off” when the hub location mode changes to “Away”. Separate automations set the hub to Away based on various situations, presence sensors, etc.

This aumotation has worked flawlessly but today I noticed it is no longer triggering - even when I force the hub to “Away” manually in the Smartthings app. The scene doesn’t get triggered, nor does History show any events other than the Hub being set to Away.

Is anyone else experiencing issues with Smart Lighting automations?

Thanks!

iOS15 on your mobile devices by chance?

1 Like

Yes, recently updated to iOS 15. Very strange behavior as other Smart Lighting automations that are triggered based on time work.

I just searched the threads and saw someone else posted a couple of minutes ago with an issue with their Ecobee thermostat setting the location mode but not having automations triggered… It seems mode is being changed but Smart Lighting is not seeing the change.

There have been a few users reporting that they are experiencing presence sensor issues since updating to iOS15 so scenes that use presence may not be working correctly. May or may not be related to what you are seeing.

Thanks JKP. Presence sensors are working fine … I even get text notifications that the hub is being set to “Away” and when I check the location mode, it is indeed changed to “Away”.
It’s about as simple a Smart Lighting automation as it gets… If Location Mode changes to Away, Run "All Lights Off " scene.

So, I created the automation outside of Smart Lighting in “Automations” and that worked. So something in Smart Lighting is no longer working.

It’s unfortunate that Smart Lighting is going away because I have several Smart Lighting automations that are time triggered with time options that aren’t available in Automations. For example, run a scene only when time is between 10:00 AM and Sunset…

I have the same issue in Webcore. Seems something changed on Smartthings firmware 39.10 about how to read/trigger location mode…

39.6 you mean… there is no 39.10 yet :slight_smile:

yes 39.6 :slight_smile: sorry
who can we report to?

thanks

I submitted a problem ticket with Smartthings Support.

To submit a ticket, go to https://support.smartthings.com and at the bottom their is an email link to submit a problem report.

Done the same…

Also having issues, The “away” automations run, but the “back” ones do not.

Same issue here. Running the Android app on a Galaxy S10. According to the app, the location mode is changing properly, but the smart lighting routines are just not triggering. This happened about a month ago and seemed to fix itself after a couple of days. But, this happening again has me quite concerned.

Same issue, submitted a problem, and they sent me a 5 page email on how to turn on location sharing for my phone facepalm

My only remaining legacy app is the ActionTiles connector. I found I could change the Location Mode using ActionTiles and the change would immediately show in the mobile app. However a change in the mobile app did not immediately show in ActionTiles. The correct mode was shown when the panel was refreshed so the legacy system seemed to have the correct value, it just isn’t sending out the change events to legacy apps.

This is also impacting me. In my case, it’s affecting both ActionTiles and Webcore.

In Webcore, I have a very simple piston that sends a webhook to Home Assistant when the location mode changes - does anyone know if that could be accomplished in the Rules API instead? That’s one of my last remaining pistons in Webcore, so perhaps this is an opportunity to clear that out.

I did a terrible hack around last night until this is resolved. I used the new automations to trigger a new virtual switch, that webcore Triggers off of, and then sends the webhook out to HA. Messy but kept me afloat for now with minimal work.

I’m also having this issue, for the last few days my Smart Lighting routines haven’t worked, and yes they use a location trigger!

I’m seeing the same problem with a couple of custom SmartApps.

Looks like this issue has been resolved and the mode change is being recognized by Smart Lighting. Support claims that my logs show that the automation was being triggered but clearly there were issues as I know they weren’t.

It’s working for me too, at least for now. Just waiting for the next failure…