I just realized that I'm unable to change Location Modes from either a classic routine or Webcore

I just noticed that I can’t set any location mode. I’ve been doing it with WebCoRE, but never actually checked if it worked. I’ve since created a couple of routines in the ST Classic app to change to various Locations, and that doesn’t work either.

I can add and remove them without issue, but for the life of me cannot change them. I even checked the IDE logs to see if something funky was going on, but I saw nothing in the logs when I attempted to execute a routine.

Any ideas?

edit: Correction. I do see this in the IDE logs

[438955db-9fd7-4d94-a6bd-0ee5b572948e](https://graph-na02-useast1.api.smartthings.com/ide/logs#438955db-9fd7-4d94-a6bd-0ee5b572948e) 9:55:54 AM: trace prefix():

[438955db-9fd7-4d94-a6bd-0ee5b572948e](https://graph-na02-useast1.api.smartthings.com/ide/logs#438955db-9fd7-4d94-a6bd-0ee5b572948e) 9:55:54 AM: info HH execute(true, null, null), newMode: Test

When you say “locations”, are you talking about actual different locations that have their own modes or “modes” within 1 location?

Assuming you are talking about changing modes within 1 location, you can do this with routines.

Assuming you are talking about changing locations…well each location is it’s own thing. You can not trigger an event in one location to do something in another location.

Yes, Im attempting to change Location Modes with Routines. It doesn’t work.

“Location.mode” is a term used in the new app (“smartthings (Samsung connect)”) To distinguish what used to just be called “modes” in the classic app from “security.modes” ( which are called “smart home monitor armed states” in the classic app).

If you’re confused about the difference between these two kinds of values, see the following FAQ:

Anyway…

“Routine” is a term used in the classic app for a specific type of automation.

So I’m pretty confused by your post because you are using a term from the new app (location.mode) With a term from the classic app (routine) and those two can’t go together.

You can use a routine in the classic app to change a mode in the classic app.

If you happen to be running both the classic app and the new app, which some people are doing, you could actually have three different kinds of modes:

Location.mode ( accessible from automations created in either app, including classic routines and webcore, but called just Mode in the Classic app)

Security.mode (accessible only from automations created in the new app)

Smart Home Monitor Armed State ( accessible only from automations created in the classic app, including routines, webcore, and the Classic app’s smart home monitor)

Location” Is a fourth value, something altogether different, and is essentially a sub account to your smartthings account. In the classic app, you could sign out and sign back in to a different location. In the new app, you can switch from one location to another in the app without having to sign out. As far as I know, you can’t change from one location to another except by manually going through that app with either app.

(There is also a “secure mode” associated with zigbee devices, but most people won’t run into that one and you don’t set it with an automation.)

So, like I said, I’m confused as to exactly what it is that you were trying to do and therefore just what it is that you are unable to do. Could you give a more specific example? What’s the value of what you were trying to change with Webcore and how did it get set in the first place.

References:

Classic app

New app

Ahhh, I learned something! I saw in WebCoRE a setting called Location Mode and assumed it was the same Mode I see in the ST Classic app. That explains why my WebCoRE piston isn’t setting my Mode.

However, I am also unable to change the (classic) Mode using a Routine. What else am I possibly missing?

edit: Wait. Location Mode in WebCoRE has the exact same values as the Mode in my ST Classic app. I am now THOROUGHLY confused.

1 Like

Okay, at least as far as WebCoRE is concerned, Location Mode and ST Classic Mode are the same thing. So as it stands, I’m unable to change my (Location) Mode from either WebCoRE or an ST Classic Routine.

1 Like

What trigger are you using to set modes in your routines… by time or presence?

Have you logged into IDE to check if your time zone and sunset/sunrise are displaying the correct times?

1 Like

My bad. :disappointed_relieved: Sorry for the confusion. Same variable, different names. I’ve corrected my post above.

In that case, let’s just start with the simplest. Create a routine in the Classic app to change the mode and post the screenshots here.

And here’s the mode after I ran it manually.

@JDRoberts (or anyone really) Sorry to bother, but any ideas?

Sorry, need to see all the screenshots for the automation from beginning to end, I was waiting until you post the rest of them.

Oh, sorry then! What else am I missing? That’s the routine I created and I posted the result immediately after it ran, which shows the mode as Home.

There should be at least three screens: one where you name it, one where you set the Mode, which might take two screenshots to show the advanced options underneath the mode field as well, and one where you save it.

Then we also need a screenshot of the message that you get after you manually run the routine

I promise that I’m competent enough to create and run a routine, but just in case…

Here’s the Routine’s name, Test (I did change the name from Away as seen in the other screenshots for the sake of clarity) and the message you get when complete. The only thing in that routine is a mode change created specifically for this exercise.

However, I’m not certain by what you mean about advanced options.

Thanks for your help!

In the field where it says “change the mode” to test, are there not some additional fields below that on the same page if you scroll down? Labeled “Additional settings” Or something like that.

Nothing of importance, right?

OK, then close the app and reopen it. Does it still show the mode as away? You won’t see the mode change in the app until you re-sync with the cloud. It will change in the cloud as soon as the routine runs, it just won’t show in the app until you re-sync. So the easiest way to do that it’s just close the app and reopen it. You don’t need to sign out or anything.

( and, yes, that’s annoying. That’s just the way it’s always worked.)

Completely closed the app in Android (not just backed out), fired it back up and the mode still shows Home.

And just to confirm, it also shows Home in the IDE
image

on the same page from the image you posted, click Edit under the banner at the top of the page, change your mode to Test and click Update. Does the mode change?