Linked Services Are Disconnected

I have added two linked services (Nanoleaf and Smart Life) and authenticated them successfully, but when viewed in the ‘Linked Services’ section they appear disconnected. When I click on either of them I pass through the steps of providing credentials which appears to work, but they still show as disconnected.

1 Like

Did the devices from those linked services populate into ST and can you control them from ST?

1 Like

Hi JKP

No to both questions.

Thanks

Andy

1 Like

You spoke about re-authenticating - Have you tried removing them and adding them back?

1 Like

Hi, @Cpants. Welcome to the SmartThings Community!

Please, let us know the results of the process mentioned by @jkp above.

If you still have issues, we would need the following information to report this behavior:

  1. Take note of the time of your last attempt to re-add the linked service and share it with us including timezone, for example: 14:50 GMT-6
  2. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM
  3. Enable support access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

Hi jkp

Sorry for the delay.

Yes, tried that, didn’t work. Took me through the same endless authentication loop and when I exit out, the linked service is disconnected.

Thx

1 Like

Two things:

  • respond to @nayelyz post to you above.
  • change the default browser on your device and authenticate to those services again :slight_smile:
1 Like

Hi nayelyz

Sorry was responding via email so didn’t see all of your message.

1 19:26 Sydney Time zone GMT +10
2 Confirmed
3 There is no “menu” option or “settings” that I can see?

Thx
Andy

1 Like

1 Like

use the following URL:
https://my.smartthings.com
after logging in… in the upper right of the screen, look for the 3 dots and tap on it to find Settings

from your posted image… you probably typed https://www.smartthings.com which redirects you to: https://www.samsung.com/us/smartthings/ (minus the us part) or https://www.samsung.com :slight_smile:

2 Likes

Done thanks. Do you need me to authenticate the linked services again, or was that earlier attempt sufficient?

Thanks!
I think I found the logs of that attempt and I asked the engineering team about the issue to see if they can find the root cause, we’ll let you know if we need another attempt or more information.

Hi, @Cpants
Following up, the engineering team looked at the logs registered in the Cloud and it seems the flow for the complete authentication is broken, so we need to dig deeper.

We need you to replicate the issue but this time we need you to send the following information at build@smartthings.com, please:

  1. Again, the date and time to find the logs easily
  2. Which OS are you using, Android or iOS?
  3. Screen recording of you replicating it to compare what you see with #4 below
  4. SmartThings app logs
1 Like