Linear GD00Z (Garage Controller) and Wall Switch (with Motion Detector)


#4

Hello, I am new to smartthings and have installed the Linear GD00Z-4 Garage Controller. I am having exactly the same issues as @mxrugg. Sensor report correct status of open or close based on position of garage door. When I open or close from ST app GD00Z-4 beeps/flashes but door does not open or close. I also have a fancy wall switch with motion/temparature sensor etc. When trouble shooting I tried to totally disconnect the wall switch from the terminal but had the same problem. I thought I had a defective GD00Z-4 until I read this post. I was almost ready to return the GD00Z-4. Appreciate any updates. Thanks.


#5

Sorry about the delay but yea I haven’t tried anything yet and I know it’s been awhile. The problem is still the “caveat” I mentioned in my post above where if I replace my existing “advanced” wall switch with a basic push button wall switch then I lose the motion sensor aspect which is what I mainly use for the garage, I really don’t care about losing the temperature reading so yea haha.

Keep in mind that the motion sensor really only plays a role if your working or moving around in the garage a lot without triggering the opening/closing of the garage door, so if that is not a concern for you then I would try to go ahead and replace your existing wall switch with a basic one from a hardware store as I mentioned in my post above.

My plan of solving the issue which I hope to do shortly within the coming months or definitely less is to just simply purchase a zwave motion sensor which runs around $45 and either a few zwave lightbulbs (for about $30 total) or a zwave light switch to control the 2 regular lightbulbs (for about $45). In this case, the lights will still come on of course when the garage is opened or closed but also if I am sayyyy moving the trash to the garbage bin in the garage without opening the garage door.

Since I want to implement more zwave devices in other sections of my house, spending that roughly $90 extra to get just my garage door working (after already spending almost $100) is what has been stopping me for several months now haha but I should have an update soon!

Let me know if you have any updates yourself!


(Jonathan Rivera) #6

Thanks for the post guys! I thought I had a bad GDOOZ until I read this post.

Has anyone had any success with this issue? I have a Liftmaster and the the GDOOZ beeps when I open or close it through the SmartThings app but it doesn’t actually trigger my garage door opener.


Linear GD00z-4 chamberlain HD210
#7

So good news and bad news! Since the weather has started to get nice again I decided to look into this issue a bit more.

So as mentioned in my first post for this thread, I went ahead and replaced my existing wall switch (with motion detector, etc) with the basic wall switch and have noticed somewhat great results. The reason I state “somewhat” is that the GD00Z will now open and close my garage door from the SmartThings app HOWEVER the clicks in the app have to be “literally” 1 minute apart meaning I can’t close the garage door immediately after I open it. If I try to immediately close the door after opening then the app will simply state “Closing” and no beeps, no nothing, it doesn’t do anything at all.

Just to reiterate in case anyone has experienced this issue, I have to wait a full minute between toggling the opening/closing state of the garage door with the SmartThings app. So if I open the garage door with the app, I have to wait one minute before I can close it again through the app. If I close the garage door with the app, I have to wait one minute before the GD00Z will start beeping again and open the garage door.

Realistically however this situation seems to be quite rare however it can be outrageously frustrating when testing it out to see if it actually works as that’s most likely what your going to do right…close the door, ok check, now open the door, oh wait doesn’t work haha so yea.

I wish I knew the explanation for why you have to wait a FULL minute before you can toggle the state of the garage door after a current toggle which I could eventually look into but hopefully someone already knows the reason or someone at SmartThings perhaps knows as well as I didn’t get around to debugging it yet. Might even be a stupid restriction in the actual GD00Z that prevents toggling states until a minute has passed as I don’t see why SmartThings would put a restriction in there for that.

@MichaelY Try out what I mentioned above and see if that works for you if you wait a full minute. However if you temporarily removed the wall switch and only the GD00Z was wired and you still couldn’t get the garage door to open or close then that might be another issue though. I was at least able to get the garage door to open, but I just had to wait a full minute before I could close it again haha!

@jrivera I can only think of two possible reasons as to why it’s not working on your end…

  1. Assuming you have wired the GD00Z in parallel with the wall switch, perhaps the wall switch is taking the full voltage to the garage door opener so the signal never gets sent even though the GD00Z beeps which was my problem.

  2. The Liftmaster might be incompatible with the GD00Z but I’m sure you probably already checked that one off your list and that’s not the issue.

It all of course depends on your setup and how you wired it so hopefully that helps out and wasn’t something which you probably already know haha!


(Jonathan Rivera) #8

Thanks man! It definitely turned out that The GD00Z is just not compatible with any MyQ devices. From what i’ve read it uses a digital signal that completely shuts out the linear. I’ve installed it on other chamberlain garage door openers and I’ll be switching out my Garage Door opener this week for a non MyQ version.

I tried a single wall switch to replace my high flying motion detector/light/controller wall switch and that did nothing.

Moral of the story to anyone else that comes across this issue… simple is better and stay away from MyQ if you’re planning on using this device.


(Chad Killingsworth) #9

I was able to get full functionality with the Linear GD00Z controller and a Smart LCD wall controller. It did take custom integration work.

Installation Overview

Instead of trying to trigger the opener directly, we’ll use the Linear GD00Z to close a relay which will close the button contacts on our smart controller and thus open our door.

Materials and Supplies

  • 4 wires (instead of the standard 2) from the opener to the smart controller. Alternatively you can mount the Linear GD00Z on the wall next to your smart controller. I used 18/5 thermostat wire.
  • A 12-volt automotive relay. The Linear GD00Z doesn’t produce enough voltage to trigger the smart controller. It will however close a relay.
  • An additional 12-volt DC power supply. I had an extra lying around from an old wireless router.

Step 1: Solder contacts to the smart lcd controller contact buttons

Since the smart controller multiplexes the signals to the opener rather than closing/opening a circuit like a dumb button, you need to use the smart controller to trigger the opener. Start by soldering two short leads to the “open” button on the smart controller.

You are looking for the contacts for either of the blue buttons at the top.

I added quick disconnects to the wires to make installation easier.

Wire the red and white thermostat wires to the standard controller contacts. Choose two other wires to connect to the newly soldered contacts. I used blue and yellow.

Step 2: Connect the wires to the relay.

The wires running to your smart controller (blue and yellow for me) connect to two poles of the relay. Make sure you connect them to the output poles - not the poles which actually close the circuit. Mine were sized for the quick disconnects so wiring was easy. The negative wire from your 12V power supply hooks to one of the input poles on the relay. The positive wire from the power supply connects to one of the Linear GD00Z wires and the other wire connects to the last pole on the relay. In other words, the positive wire from the 12V power supply goes through the Linear GD00Z to connect to the relay.

Step 3: Connect the Smart Controller To Your Opener

The red and white wires connect to the opener as normal. Plug the opener, Linear GD00Z and the relay power supply in and test the whole system.

My smart controller is fully functional and my Linear GD00Z is as well.


GD00Z-4 Garage opener doesn't work...sort of
Problem controling my Lift Master 8500
#10

I got a GD00Z-4 working with a Liftmaster MyQ system as well. The trick was to get a universal wireless remote and solder some leads from the switch to the Linear’s Pushbutton terminals. I also wired in a 3v power adapter to the remote so I would never have to replace the battery. You can get these at radioshack for under $10. It all works … mostly. I noticed that it was intermittent until I came to this thread and read what mxrugg said:

“Just to reiterate in case anyone has experienced this issue, I
have to wait a full minute between toggling the opening/closing state of
the garage door with the SmartThings app. So if I open the
garage door with the app, I have to wait one minute before I can close
it again through the app. If I close the garage door with the app, I
have to wait one minute before the GD00Z will start beeping again and
open the garage door.”

I’m not hooked up to a SmartThings hub. I’m hooked up to a Honeywell Tuxedo Wifi (new firmware fully supports the Linear). I wasn’t sure why it would literally stop working… until I waited the “minute” before re-openining/closing. Voila… I got 100% when I waited.

This looks like its a thing in the Linear GD00Z. It may have to do with the communication between the tilt sensor and the unit before it allows it to recycle itself. I may experiment by pulling the tilt sensor completely and seeing if I get more consistent results.

This does not seem to be documented anywhere, but IMHO, its a serious problem. I may contact Linear to see if this is a bug or its by design.

Can anyone else have the ability to open/close the Linear under a minute consistently w/o having it force itself into manual mode?


(Paul Bockmann) #11

I have a Tuxedo Touch, a number of Cooper Aspire wireless switches, Vista 21IP security, Yale Real Living Garage door lock, and Linear GD00Z-4 garage door command. My garage door openers are Liftmaster 3800-PLD, but I only wanted to control one of them with the GD00Z-4. My Liftmasters use the smart control with temperature and motion sensor, and I did not want top lose that functionality or anything else for that matter. So I was interested to stumble across your post. I just got through installing it and it works perfectly - everything works. I can run and and monitor the garage door from the Tuxedo Touch, from my car’s button, from the switch, and from the Honeywell Total Connect 2 app on my computer and iphone. Right now it is set up somewhat temporary for testing purposes, but I will clean-up the install this week and it will look and operate perfect.
Thanks fo rthe post and hopefully I will be able to add something to this later.


#12

Hey there, awesome troubleshooting! Just curious if you ever got around to contacting Linear for their confirmation on indeed if it’s intended behavior or an actual bug. I’m hoping the second but knowing lawsuits now days I can only imagine it’s intended behavior so no one will come after them for someone triggering it rapidly in a short period of time breaking the gears or whatever with the garage door or somehow injuring someone, who knowsssss but yea haha!

Hey sorry if I misunderstood but did you mention you actually got everything working with a GD00Z-4 hooked into the same terminals as your premium wall switches (aka includes temperature and motion sensor)?

If so, then that’s great as you got the best of all worlds and perhaps your garage door opener allows more customization so that’s why it worked?


(Paul Bockmann) #13

I believe everything is working fine on my unit - The temperature reads fine, lights turn on when it senses walking or when the door goes up. I have attached a couple pictures showing which door-opener button I have and the GD00Z-4 installed on wall above garage door. I used the 12V power supply from the Linear GD00Z-4 transformer to drive the Radio Shack (YH185B) relay and the GD00Z-4 - and it works fine. Inside the door-opener button, I soldered the wire across both of the switches just to be sure there was no questioning this interface. After all was hooked up and powered on, everything works as it was designed.


(Paul Bockmann) #14


#15

@mxrugg in the installation instructions it states

“Once the GD00Z-4 has initiated the movement of the garage door, another
command cannot be sent for 30 seconds. This eliminates the chance of “bouncing”
the garage door and possibly damaging the garage door opener.”

They state 30 seconds, not a minute, but since it seems like a common issue it is likely an intentional feature in the GDOOZ.


#16

The 30 seconds is a UL listing requirement for garage door controllers that can be operated out of sight. But it’s 30 seconds, not a minute.


#17

Well at this point I rarely use my garage door controller hooked up to SmartThings due to security concerns of the hub possibly malfunctioning and just opening the garage even though chances of that happening are probably unlikely, I just had bad luck with SmartThings so will take a while to gain my trust back slowely haha!

Also the largest issue I have with the system is that the “smallest” radius we can select in the phone app is still way to large for me as where I’m located there are windy roads all around so chances are you can be driving on the road near the “back” of the house but by the time you reach the front, the garage would’ve already been opened for 45 seconds or more which is unacceptable to me. Even while leaving the house, I want the garage to automatically close after 5 seconds of physically leaving the garage where I can still see it physically close instead of turning down a street and now I lost sight with the front of the house so yea!

Everyone has their use for this controller but to me, it’s just a simple fancy gadget I show friends and family and is really of no use unless SmartThings lets me create a smaller presense location radius in the app. I mean not everybody lives on a straight street with a farm field in the back right? :smile:


#18

Thank you for posting this. I believe I have the same garage system. How did you use the same power supply to run the gd00z and RadioShack relay? Thanks!
J


(Paul Bockmann) #19

It has been a little while since I did this, but I believe I ran the positive lead from the GD00Z’s transformer down to the relay, where I cut the wire, and tied the positive wire from the GD00Z to the other connection on the relay.
I followed the basic format as presented by Chadkillingsworth earlier - I just cleaned up the install. It has been running now for a couple months now and all is good.
I will get a few more close-up photos and post them; Those would show the wiring details at the relay.
Paul


(Brad) #20

Okay, I just got one of these and I’m in the wonderful situation (despite none of the exclusion manuals listing my model) of having the same opener / wall remote that chadkillingsworth does. Why they don’t say “any smart LCD temperature displays are excluded from compatibility” as well is beyond me.

All my wiring was done pre-build and is inside the walls and ceiling, so I have no interest in exposed wire from my wall pushbutton up and over to my opener.

That said, can I still use the solution of buying a cheap wireless remote, jumping 2 wires to the red/white inputs of the opener, and the other 2 white wire leads from the zwave device, and just having the remote up there? I don’t care about the remote battery dying – If it happens I’ll climb up once a year or whatever and put in a new battery. I am crap at soldering and electronics.

This was supposed to be easy. Frustrated. The opener chad and I have IS Craftsman but not MyQ technology so I am a little irate that it wasn’t clearly listed on the exclusions list. Pretty popular unit.


(phil) #21

Because I have a lift master and this is my only solution

  1. Do you still have it working since it has been a few months.
  2. Can you get me some pictures of the remote and how you have it set up.

I think this is the best and cheapest option and still be able to use the smart controls on the door opener. Very ingenious.


#22

Yes it is still working… works fine. I had more issues with the ZWave with my Honeywell’s so I needed a repeater to make it solid.

I need to climb up and get pictures…I’ll see if I can get time to do it.

Its really easy. When you open the remote there is a switch on the push button. You want to solder your GD00Z leads to either side of the switch. The GD00Z, when it activates, just creates a short, so by putting those on either side of the switch, you are essentially shorting out the switch and activating the remote.

For the voltage, you just get a transformer from Radioshack or Walmart that matches the voltage of your remote. Mine happened to use a 3v lithium battery, so I got a 3v transformer. Solder the positive wire from the transformer to the positive of the remote and the negative to the negative of the remote and plug in the transformer. Oh… and be sure to remove the battery too… you don’t need it any more. If you don’t really care, you can probably bypass the transformer and just use a battery in the remote. Most remotes will last several years before you need to change the battery. I just didn’t want the headache, so I hard wired the remote to make a more permanent solution.


(phil) #23

Would be cool to see pictures and I am sure there are others that would also like to see it. Thx for getting back