Lightify - not detecting some lights (A 60 RGB bulb)

Hi all, I am new smart things. I bought some Osram Lightify bulbs which worked fine with the base station. But once when I removed them from there connected SmartThings I am having trouble with some of the lights been detected, even thought I tried several times to switch on and off and discover devices. Can anyone please shed some light or tips for me to do it

Something similar happened to me with my SYLVANIA Smart BR30 RGBW which is lightify as well.
It wouldn’t discover properly. It kept showing up as thing… I wish I would have take some screen shots. But anyways if this is similar, what I did to fix, was log into, click on my locations, then home, then my devices, and find it on the list. scroll to the bottom and click on edit. Change type to ZigBee RGBW Bulb. You have to scroll down the list to find it. Then save. Go back to the app and it was there for me.

edit: you can also read through this… it may help.

1 Like

Thanks Scott2ya. Worked perfectly.