Lightify bulbs coming on and staying on

I have a few lightify bulbs on one bank controlled by ST. I don’t have the Lightify Hub, they are just synced direct to ST hub. Work fine.

I have an automation to switch them on between sunset-sunrise if motion detected by specific ST motion sensors. They turn off after no motion of 5 mins. This is in the Smart Lighting smartapp.

However I’m finding them on when shouldn’t be. I look in the iOS app, I can see in the recently tab it says bulb on, but not why, and I don’t know why they are not turning off either.

Anything I can do to check to see why on, and why not switching off?

After disabling ota updates no random unexplained on lights.

Check this Smart bulb randomly turns on

Funnily enough I’ve just been asked by ST support to enable OTA as been having bother with my ST motion detect battery saying 100% and dieing, so the OTA wasn’t on.

Lol nevermind

There are three cases of Lightify bulbs automatically turning on that I know of.

  1. A power cycle of the bulb, such as a power loss.

  2. During OTA firmware updates, the bulb will reset. This should only happen once after the update.

  3. Very old firmware was shown to cause resets when high ZigBee traffic was routed through the bulb. Enabling OTA updates and updating to the newer firmware should resolve this.

Came down this morning and they are in a bank of 3 off one light switch. After sunrise so rule shouldn’t run.

When I walked downstairs randomly 1 bulb came on, when shouldn’t…I switched it off at the wall as sick of the randomness, and unsure of they are staying on all night.

Without the lightify hub is there any way to get a firmware update?

What’s else can I do, looking on the logs in the graph show nothing either

If you are in the US, the existing firmware version 17 has updates for the Lightify bulbs. As long as OTA and bulb OTA are enabled they will get updates. Unfortunately, I’m not sure about the UK. I believe version 18 has some UK firmware updates, don’t know if it contains new Lightify firmware.

I have 10 Lightify bulbs and have not had many of the issues that plagued a lot of the users. I did recently have one bulb kind of go braindead. It would work for a very short period, then only sending it an on command would work. I would manually cut power, turn it off, and could control it. Later in the day it would turn on and then not turn back off. I fixed it by cutting it’s power for 15 minutes, then plugged it back in. Been fine ever since.

I thought that if you didn’t have the lightify hub and just used the lightify bulbs directly with ST hub then you wouldn’t get any firmware updates for the lightify bulbs?

In UK yes we are on FW 18.18 now. I have via the graph IDE enabled FW OTA and the bulbs but nothing seems to happen, how do I know if they have updated?

So just switching off the lighting bank at the wall switch for a while may help as well? Normally the wall switch is on all the time and ST controls the bulbs.


I’m guessing there are no Lightify firmware updates available in the UK. You can confirm by looking in IDE. It should list current version (and target version). It is likely you don’t have updates if the target and current version is the same and the last updated field is blank. However, the only surefire way to see if there are no updates, is to see different target versions for different devices of the same type. Hopefully that makes sense.

The bulb should always be powered. The only thing I was saying is that I needed to power one bulb off for at least 15 minutes to have it do a full rejoin of the network. After that point I kept it powered.

I thought you had to have the lightify hub to get firmware updates though? I don’t and it’s connected directly to ST hub is yours?

Don’t have a target and current just a “check now”

I’m in the US. We do have direct firmware updates for the Lightify bulbs. If you just have a check now button, there definitely are no firmware updates. As a note, Lightify firmware in the US is ZHA (ZigBee Home Automation), those in the UK are ZLL (ZigBee Light Link). I’m, not sure why OSRAM made different firmware specs (though in the US everything is now branded Sylvania).

I had heard that some users connected their Lightify bulbs to Hue so I assumed they all were ZLL. When I tried to get some Lightify bulbs to connect to Ikea remotes, I realized they are ZHA in the US.

My house is entirely lit by lightify now… And having lived through all the early firmware issues of random light activation or sulking… I’ve been mostly happy for better part of a year… Ok one of our porch lights randomly ignores it’s off command but that’s outside so it out of sight… right lol.

Since this hub update I’ve had 3 GU10s reported as unavailable (in a single switched bank of 7 arrgh)
And a couple of others as well.

Most just needed a power cycle

The GU10s have just taken 4 bulb factory resets and moving the hub temporarily into the living room to get them all back active in smart things… Definitely related to the hub update and as we do have firmware updates for lightify in the UK (according to my graph devices page) it’s quite possible that the “update 5 devices” at a time piece isn’t working properly…

Still having problems. Came back after a few days away where I had the lightifys coming on/off to find one still on at 1pm. These are in a bank of 3 and all have same routines/automations. So I’ve no idea if they worked when away etc.

I even have an “all off” to hopefully override all through the night at sunrise +30 mins. My hope was this would turn all off no matter what.

It’s supposed to be used for security lighting, emulate I’m away, but it’s probably doing the opposite when this happens.

I was going to buy more, nearly did, but this has stopped me again. Will they work better if I get the lightify hub? I do t want to but if helps then I’ll have to.

Well I bought a Lightify hub to update them, went well, but in ST it still shows one as current N/A, but it did seem to work in the Lightify app and showed it had updated. Could this bulb be faulty somehow?

I’ve added them back to ST and all seems to be working but this isn’t right, the others show below?

Also whats the latest/best DH to use for these standard white GU10 in UK please? I added them a while ago so maybe its an old DH, or do they not go old as such?