LIFX integration stopped working

lifx
smartlighting
smartbulb

#1

Anyone else have this issue?


(sidjohn1) #2

Works great over here


#3

Looks like I needed to re-login into the app to get things working again. Never had that problem before.


(Eric) #4

for me the ST-LIFX integration stopped 2-4 months ago so ST routines failed. The LIFX-app also lost control of the devices. LIFX logout-login re-established LIFX-app control of those devices but the ST-LIFX (Connect) integration still fails - attempted integration login says "{error: true "… You are not authorized "…

so I expect I’ll have to delete all existing ST-LIFX integration routines and devices, restart the ST-LIFX integration, and re-install those routines. WebCore should make it easier to restore these in the future but it’s not as straightforward as Core or Rule Machine.


#5

Before you delete anything, open the LIFX (Connect) SmartApp under Automation/SmartApps on your mobile app. Make sure that it displays a valid Location of your LIFX lights (as the are stored in LIFX) and Save the application until it takes you back out to the main SmartApps page. It rediscovers and pulls all your lights back in. That and reconnecting / linking ST and LIFX might get you going again.


(Eric) #6

thanks for this procedure-

my ST- LIFX(Connect) only says “Connect to LIFX”/ Tap here to connect your LIFX… no other info, no location. So I “tap there” and get the error “You are not authorized”.

I looked around in IDE previously and it seemed I could have no effect on it (ST error “something is wrong”) until all the existing ST-LIFX devices are deleted via phone-app.

parameter “selectedLocationId” value looks plausible,
“accessToken” value looks plausible,
“lifxAccessToken” value is blank,
“devices” 5 listed like {d073dxxxxxxx=null,

I’da thought lifxAccessToken would have something in it.

Not a big deal, I just expect to delete everything LIFX and restart.


#7

The whole you are not authorized has been happening lately. Most for those folks trying to make a change in the IDE, but this could be related. I would hold off on deleting so you don’t make things worse.

Are you in the US or the UK? If the latter, there are more troubles today.


(Joel) #8

mine also stopped working came here to see if others had same issue.


(steve grout) #9

Had the same thing happen to me today!

@WB70 thanks very much for your tip. I had to reauthorize the link to LIFX for some reason.


(Pete) #10

I also had to do the procedure within SmartAps to re-connect the account to the Smartapp. Is there any way to know why it stops working? I am glad this resolved it but the WAF goes down when odd things like this occur and my scripts stop working that allows her to say “Alexa turn off all lights”. It would not turn on or off Lifx lights to she had to power them of manually. I know, who is me right? When you get used to using automation and are trying to talk others into it hiccups like this are annoying.
Any way, thanks for the advice on repairing!


#11

My SmartThings/LIFX has been dead for three days now. Tried a reboot of the hub but came here for the answers. Will try ‘the procedure’ :grinning:

EDIT:- Yup all working now :raised_hands:t2::raised_hands:t2::raised_hands:t2:


(Joel) #12

Which device types are you all using ? Standard st one or custom device ? I find the two custom device types (lifx group and lifx group of groups )are not stable


(Eric) #13

I just tested one color, worked ok, type “LIFX Color Bulb” - 1113 EDT. I use hub-v1.