Lifx colour help!


right im at my wits end HOW THE HELL DO I GET MY LIFX COLOUR BULB (latest firmware) to work with my ST?? the online guide supplied online by samsung is null and void for me (the LIFX option doesnt appear under bulbs)

i have tried adding the smart app LIFX (connect) but when running this on my android phone (htc m9 android 5.1) i get a red banner slide down saying 'you are not authorised to perform that request)

i did try the updated LIFX 2.0 code i found somewhere but this did not discover any bulbs either.

sorry ive tried to cover what technical information i know while im no idiot :wink: huh hum my knowledge of this coding is very basic

if you can PLEASE HELP

ok sorted out the authorisation problem but now on the ST developers page for my device when running the simulator i now get this message …

groovy.lang.MissingMethodException: No signature of method: java.util.ArrayList.error() is applicable for argument types: (org.codehaus.groovy.runtime.GStringImpl) values: [got error: Unauthorized, body: [message:Invalid token]]
Possible solutions: sort(), drop(int), drop(int), clear(), iterator(), clear() @ line 302

in the app when running the Connect to LIFX smartapp i get a blank page when tapping to connect my LIFX account

Are you one of the new European customers running on the new UK SmartThings servers?

If you are, you won’t be able to get LIFX working until they fix the OAuth issue that affects users on those servers. The SmartThings<–>LIFX integration is between the SmartThings cloud and the LIFX cloud and requires OAuth authentication to work (just like IFTTT).

You can read about and track the status of this problem here: