Leviton zwave dimmer network error

One of my zwave leviton dimmers keeps going offline. I remove it, do the z-wave exclusion, re-add it, it works for 5 minutes, then I keep getting a network error. I can shut it off with the app, but cannot turn it on. All the others work fine.

Have you tried running a z-wave repair?

Have you done the firmware update to 1.20?

Yes I’ve ran the zwave repair several times!

@Blaine which item? The dimmer or the hub? The hub has the lastest firmware 26.2. Thanks!

I was speaking of the Leviton dimmer firmware. There are a couple of threads here regarding it. you can search on Leviton, or the model number. I will try to post a link when I’m at my computer.



+1 this

A number of us have had this issue with Leviton switches and dimmers. Firmware upgrade has fixed it for everyone so far.

Call Leviton support and explain the problem. They will send you a loaner Z-wave USB stick and info to update your device(s).

Or, buy a Z-wave stick and the Homeseer Z-flash software.