Losing control over Leviton VRMX1

I have a bunch of Leviton VRMX1 dimmers and they have been working fine for a while (6-12 months), but now I’m starting to lose them one by one. They work just fine when operated manually but I lose the ability to turn them on/off programmatically and they won’t report their status change to ST. They sometimes work after several tries, but it is getting worse and worse. All my other devices from different brands work just fine. I did pair most, if not all those dimmers using a minimote.
Any hints? Thanks!

If you paired them with a Minimote, you lost their most valuable feature, which is instant reporting. That feature is why they cost more than other Leviton dimmers. They have to be paired directly to the hub in order to do instant reporting.

However, that is probably not your immediate problem. It sounds as though the health of your z-wave network is dubious. You say that you have other z-wave devices that work fine. It could be that you have a bad device in the mix. A single bad device can drag down your entire z-wave network. I’d be suspicious in particular of any older GE z-wave switch.

Have you performed a z-wave network repair? If not, you should start with that. You can find plenty of discussion here about how to do that.

1 Like

I do have a whole lot of z-wave devices from different brand, including GE switches. I did do a Z-Wave Repair last night and it’s worse this morning. How do I hunt down the culprit?

It’s getting worse, I have lost control over most of my Z-Wave devices… I will try a repair…

After a Z-Wave network repair, I have 14 devices failing the process with various error message:

Did not finish updating mesh info
Failed to update mesh info
Failed to update route
Could not assign new route

Short of uninstalling all 14 devices, any idea what I should start with?

I have the 2 button load/scene controller, and every once in a while I need to completely cycle power to it via my breaker. That always “woke” it up for me.

What you’re experiencing is what I’ve gone through with my Leviton device. After power cycling it, I’ll get instant reporting to work again for a while, and then it stops. I’ve resorted to using Pollster on just that 1 device.

Because of the switch location, the inability to add another physical device, and very limited room in the gang box I was stuck with using the Leviton. As soon as something better comes along, I’ll be getting rid of it.

Try cycling power to your Leviton devices, and then see if you can control them in ST again.

I cut the house main power switch and turned it back after a couple of minutes. I then did another Z-wave repair. I’m now getting other devices failing…

I do see 7 of what appears to be ghost devices, they are named like “device [10]”. How I get rid of those?

Unfortunately they’re going to hang around for a while. There’s a discussion in the Community about a manual method, but that’s not worked well for me. I’ve also emailed and communicated with support on this for some time. They can try on their end to delete these, but they do admit to an issue on their end that needed worked on. Who knows when that will happen.

As the other reply mentioned, you may have a device failing that’s causing your mesh to get wonky. I did have to replace a couple very old GE devices a while back, so keep that in mind in case you have a few of those too.

Since you have a few devices in the repair failing, you want to pay attention to the devices and what error messages you’re getting. In your post above, look closer at the devices that are giving you those last 2 messages, especially the last message. That message is a good indication of a device that needs to be power cycled, or readded to your mesh.

Here’s what I’d do. Go to each device causing you problems, and attempt to do a Replace via the phone app via the device’s preferences (the little gear in the upper right corner).

Don’t try to control the device via the app right before you try a Replace so that you don’t have a bunch of zwave messages trying to work through your mesh. Just go to the physical device and start the Replace process. If ST can see the device, then that device is OK - even if it takes a few minutes. You know when you find the problem device when the Replace process comes back and tells you it needs to replace/rediscover it. When that happens just tap on or off, a few times just as if you were including it for the first time.

Also, if the Replace process times out, I’ve found that rebooting the hub may be required.

I have three devices giving me the “Could not assign a new route” error. A minimote, a GE In-Wall Smart Outlet and one ghost device.

The minimote seems to work fine despite the error message. The Outlet however has been unresponsive for a while. Come to think of it, it might have been the first failing device. I will try “replace” and if that doesn’t work I’ll just unpair it. I don’t really need to automate it anyway.

Thanks you for helping!

1 Like

So I excluded the GE In-Wall Smart Outlet from the system and everything started to work again.

Thank you John and Peter for your help!

1 Like

HaHa! I was going to suggest that you might have to start removing devices, doing a repair, etc, rinse and repeat, until the problem clears up. Some guys had to remove every z-wave device and rebuild.

It’s amazing that a single device can bring the whole thing down, not cool!!