Leviton Z-Wave Switches (and other devices) not responding

Thanks guys. I tried removing the switch that was only showing up as “connected”. Had to force remove it via the IDE. After that I put my hub in exclusion mode and followed the exclusion instructions for my switch. Added the switch back to the app using the inclusion instructions. Smartthings recognized the switch and added it. However, it showed up again only as “connected”. No controls from the app or ability to voice control Google Home to turn it on/off. I did the same to my undercabinet lighting which is on a Leviton dimmer Z-wave. Exact same result. Frustrated, I gave up and figured I would need to find the time to pretty much redo everything. I have a good morning routine that I run every morning while eating breakfast and getting the kids ready. Weather, reminder, news, etc. It also turns on several lights. After saying “Good Morning, Google” all my kitchen lights turned on. 2 out of the 4 of these were having said issues. Encouraged, I asked Google to turn on the living room light. On again. Went through every switch I was having issues with and all is back to normal. Not sure how or why, but I’m not complaining!!

I appreciate the time you all took to help me out. Much appreciated!!!

1 Like

That’s great!! Out of curiosity, can you check if the devices now show up in the SmartThings app with an Edge driver?

To check:

  1. Open the app on your phone, click on the device
  2. click on the 3 dots in the top right corner
  3. If one of the options says “Driver”, that device is using an Edge driver. If that’s the case, click the Driver option and see what it says (which Edge driver it’s using).

No big deal if you don’t have time for it, I’m just curious.

1 Like

Here is a screen shot of my one switch I was having issues with. Someone (maybe yourself?) mentioned that in the IDE under type if placeholder was listed it meant that particular device was using edge drivers. All my switches have placeholder in that slot. Placeholder was also there before the issues were fixed. Doesn’t look like anything changed in that regard.

Yes that’s using the Production Edge driver from Samsung. Notice that the version of the driver has yesterday’s date, so it’s possible that your problems were also caused by the driver and once they pushed out the new version (sometime between yesterday and today) that’s what fixed the problem. Who knows!! Glad you’re working though!!