Kwikset deadbolt keypad doesn't always work

Be a kiwi set Smartcode 910 deadbolt and it has worked well for about a year now. For the past couple weeks though they keypad has been acting flaky. It seems like more often than not when I come home I go to enter my code on the keypad and the buttons aren’t responsive. They don’t light up and they don’t beep. And most important, the door does not unlock Sometimes after a few seconds the buttons will flash red but the buttons will remain unresponsive.

Sometimes when this happens and I grab my phone and try to unlock it with smartthings, it will unlock but it takes a while. Maybe I p-60 seconds.

Any ides what could be going wrong here?

When did you last change the batteries?

Keypad failure is almost always either low battery power or actual device failure. It can be something as simple as a connection having come loose. It’s rarely a network problem.

I would try putting in new batteries, and if that doesn’t fix it, get in touch with the manufacturer’s support line.

I changed the batteries about 3-4 weeks ago. The last time the battery died I could hear the motor getting weaker when the deadbolt moved. It seems to be operating with full force at the moment. Maybe the wire came loose?

Could be, that can happen. I’d talk to Kwikset support.

Did you get any resolution? I’m having the identical problem after fresh batteries.

Our keypad light quit working months ago. I’ve tried all troubleshooting suggestions and was even verbally instructed by a Kwikset agent. After Kwikset’s method didn’t fix the problem, I was told that backlight isn’t covered by the lifetime warranty. I bought the same model and installed tonight…NO BACKLIGHT! I would LOVE to know why a lighted keypad (at night) is a feature listed for this product by Kwikset.