Kwikset 914 Zigbee will not connect to ST

Sorry for this rather long saga but here we go. I bought a new Kwikset 914 Zigbee smart lock and while installing I accidentally used the wrong screws to mount the motor assembly to the mounting plate and the pointed heads punctured the motor which rendered it useless in terms of actuating the deadbolt except for manual turning. I was able to connect it though quite easily to my ST v3 hub. After realizing what had happened I found the used motor assembly (less chipset) on eBay and bought one with the idea of removing the Zigbee chip and reinserting it in the used assembly which I have read several posting can be done quite easily (you can even get a Z-wave chip if you want). In the meantime I also called KWS to see if I could get just a new motor assembly and they said they do not offer just that part but to my surprise they sent me a brand new lock (they are a great customer service company). I then figured, out of the two I can resolve the issue.
When I installed the eBay assembly and reinserted the chipset everything looked good BUT I could not get it connected to my ST hub. I have tried every troubleshooting pairing suggestion I could find (resetting the hub, resetting the lock, moving the hub to within inches of the lock, deleting/reinstalling my ST app, assuring the chipset is well seated in the assembly as well as all the KWS online suggestions. I also tried to connect back the old assembly which had paired easily during the original installation and the same problem, could not connect (time out in ST). At that point I thought maybe I damaged or improperly inserted the chipset so I opened the new unit with the Zigbee chip factory installed in the slot and to my disappointment it would not connect either.
I have to think this is some type of ST issue since 2 different locks with 2 different chipsets will not connect. I have read a post in the Community from a couple of years ago that someone had a similar issue with a Z-wave 914 but was able to resolve it by following one of the steps that I have tried to no avail.
Since it connected the first time during installation why can I not connect the same and new chipset now???

There can be several reasons for this, but the usual is that you have to clear the prior network information from the lock before you can add it again.

As always, the first rule of home automation applies: “the model number matters.“ In this case, it is very important to understand that Zwave and Zigbee are two completely different network protocols, with their own ways of joining and their own utilities. Information about using a Z wave module will be irrelevant to a lock with a Zigbee module and vice versa.

So, let’s start with the user manual and see what the instructions are for Zigbee. Here are those reset instructions

Delete, default, and pair lock again:
iii. Press and hold the “Program” button while reinserting the battery pack. Keep holding the button for 30 seconds until the lock beeps and the status LED flashes red.
iv. Press the “Program” button momentarily.
v. After several seconds, the lock will flash the status
LED red and green several times and beeps twice (if audio is enabled) to indicate factory reset is complete.
c. For model 910 or 914, perform handing on the lock. For model 916, it will automatically perform handing.
d. Pair the lock with TS again.

Notice that This has a couple of steps which follow a very common Zigbee protocol: you hold in a button on the device while you are replacing the battery. This will cause a reset, and again, in a typical Zigbee fashion, there will be a change in the status lights on the device to show you that the reset has occurred.

Zwave is done in a very different fashion, you don’t have this thing about holding in some button while you restore power. You just have a command you can send to reset it. But anyway, you don’t have the Z wave module, you have the Zigbee, so you have to do the steps above to reset.

As to why you were having problems with the new device, I don’t know. It sometimes happens that one gets shipped from the factory that had previously been connected to a test network and they forgot to clear the information before they sent it out. So the steps for that would be the same as those above.

It’s also possible that there’s something wrong with your hub, that can happen, but let’s start by just focusing on doing a zigbee reset. and see if it works. :thinking:

Thank you but I did perform this reset previously and now just did it again and still no luck. I have no issues connecting with other zigbee devices in my home and am totally puzzled. This is a very popular and quality smart lock with few connection issues from reviews I have read. :confused:

It’s a very popular budget smart lock, definitely. (It’s a quality level below Yale and Schlage, including in the independent ANSI ratings, but that’s why it costs less.)

So when you follow the Zigbee reset steps in the manual, do you see the LED color changes as described? First it just blinks red, then you push the program button, then it blinks red and green. Do you hear the double beep after that?

Yes I see and hear all of this and it appears to have reset. However when I try to pair it to ST per the process (press A button 4 times) it just can’t connect. When unsuccessful I also did the 9 presses of B button and then back to A for 4 presses but nothing. I tried the factory reset on both the original and the new assembly/board but no success on either. I do notice my ST hub is blinking green during the pairing process and trying to find it before it times out. Not sure who to call, KWS or ST support?

I’m sure that’s very frustrating. :disappointed_relieved:

I would start with Kwikset support and see what they say. They may then refer you over to smartthings, but I think you’ll get the quickest response by starting with them.


I was able to contact Samsung support first thing this morning and it turned out to be a simple fix. I had forgotten (and it is not documented anywhere that I can recall) that you need to connect your devices to the ST hub at 2.4 GHz. I have an eero mesh 2 band system and it was trying to jump on my 5 GHz band used in connecting to the hub. I simply paused the 5 GHz and forced everything to 2.4 GHz and bingo it connected right away. Samsung Tech Support said ALL devices connecting to the hub must do so on 2.4 BUT I have connected my Kasa wifi switches to the hub without the need to pause the 5 band but others I have had to connect only on 2.4 (I just forgot about this). I guess as it has so many times been stated “the model number makes a difference”.

1 Like

Trying to understand how pausing a WiFi radio lets a Zigbee device connect . . .

It wouldn’t have anything to do with the Zigbee connection. It was the app that was hanging up.

That’s a very common issue when adding a lot of cloud connected devices. I’ll admit it seems odd for a hub connected device, but it’s not impossible.

Unless of course it wasn’t anything to do with that at all, and it was just Wi-Fi interfering with zigbee. That’s another problem that can occur with zigbee Devices, although if it was that I would expect the problem to come back once the Wi-Fi 5.0 GHz band was re-enabled. :thinking:

1 Like

Not really sure but I have other zigbee devices (bulbs) that would only connect to the hub using 2.4. My limited understanding is that the device/app uses wifi to make the original connection to the hub and then uses its own protocol (zigbee or zwave) for communicating after established on the hub. I may be way off but all I know is it worked immediately on both my zigbee locks once I paused the 5GHz. I have a zwave lock coming too so will be interesting to see how that connects to my ST hub. Thanks for all the comments and suggestions. Although far from where I want to be I am learning so much from all you experts. Will be starting to dive into some native automation next, so I know I will be asking more questions. :roll_eyes:

Two separate things are happening for a zigbee or Z wave device which does not itself have a Wi-Fi radio.

Those devices do not talk to your hub via Wi-Fi ever. they join to your hub using the regular Z wave or Zigbee protocol.

The issue that comes up is that smartthings is primarily a cloud-based platform and even its own app cannot talk to its hub without going through the smartthings cloud first.

So you get this weird situation where the app talks to the cloud via Wi-Fi, the cloud talks to the hub via Wi-Fi, then the hub talks to the end device via the Zigbee or Z wave protocol. You can’t “just add the device to the hub“ without this cloud component, so that’s how Wi-Fi can come into the picture, particularly for a hub which is using Wi-Fi rather than ethernet to get to the smartthings cloud.

If a device has its own app (that doesn’t require its own hub) then either that device also has a Wi-Fi radio or it has a bridge device with a Wi-Fi radio. This is where the first rule of home automation comes into effect: “the model number matters.”

For example, August locks have Wi-Fi, either in the lock itself or in a separate bridge device.

And in the category of “the model number matters,“ there’s even a special wrinkle with this particular lock in that the 914 model actually comes in several different versions. One is intended for use with the Amazon key system and has some different wrinkles in the installation process and it does expect an app to be involved. So much weirdness ensues. it is possible to add that model to a smartthings set up, but it is a slightly different procedure than adding the other 914 model. :thinking:

So anyway, it’s not the process of adding a Zigbee or Z wave device to a hub which has anything to do with your Wi-Fi band. It doesn’t, except for potential interference.

It’s the fact that these days many smart locks have some kind of app involved, even if it’s just obviously the smartthings app, and then you start running into the Wi-Fi band issues during set up.