Kwikset 912 Lever Lock: Can’t Add Codes with Stock Edge Driver

Thank you for the confirmation!
Can you please tell me if you can change lock codes remotely using the ST app?
I installed Kwikset deadbolt and lever yesterday, the deadbolt I can add and delete codes fine,
but the lever lock I don’t see any codes in the app and when I try to add one it ends in error.
It locks and unlocks fine though.

Both locks were installed using ST default I did not add this driver yet.


You’re Welcome.

Are you using the Smart Lock Guest Access App (found under the Life tab) ?

When I first pressed “Lock Codes” (found in the upper-left “locks” dropdown), the Kwikset did not show up in the list of codes. But as soon as I clicked “Invite Guest”, selected the Kwikset, and added a code, it showed up and I was able to program 8 codes.

Can you confirm that you’re using “Edge” Drivers as well as which driver ? Go to the Lock Device Card > 3-Dots Menu > “Driver” (if "driver does not exist, then you’re still using the old pre-Edge Drivers).

1 Like

Yes, that’s the same way I tried to add codes for both locks.
Looks like both locks are using the old device handlers ( none custom handlers installed by me) not edge.
Will install this driver and try to pair them again!

Thank you for your time, and thanks to OP for all the work on this project! :slight_smile:

1 Like

So, let me update on my experience trying 3 different EDGE drivers ( PH v1.00, PH Beta, Z-Wave lock ST beta)
Hub v2 and the model number on the Z-Wave module in the Kwikset 912 lock is 450241.

I can lock unlock from the app but the lock will not report status to the app if change was done on the keypad of the lock.
Adding codes reports as error ( after about 45s) Surprisingly the code is actually added to the lock but will only show up in the app if you change the driver.
(I presume it updates the status)

All 3 drivers tested same result :frowning:

Understood,the stock driver is behaving the same way, I’m unable to add codes.
Just wanted to report back since John reported that it does work for him on the same lock.

Not sure why it doesn’t work for me :frowning:

Once you have added your locks and you have confirmed that they are using Edge drivers, delete SLGA and re-install it. I had problems with SLGA throwing errors when trying to add codes to one of my locks and this fixed it.

1 Like

Thanks for reply Bruce!
I will look stupid now but I have no idea what is SLGA , search only found
Saskatchewan Liquor and Gaming Authority
…I presume that ain’t it :rofl:

Smart Lock Guest Access is the ST “app” that can be used to add/remove lock codes. It’s found in the Life tab in the ST app.

1 Like

Got it, will try.
What I find strange that it doesn’t even report back status of the lock when you lock/unlock from the keypad.


Will need to look at the logging from the driver to dig deeper into what might be going on. Install the ST CLI and use the command “smartthings edge:drivers:logcat --hub-address=xx.xx.xx.xx” to capture what the device is doing.

Will do, for now, tried to delete and reinstall the SLGA and no change

As with status reporting, it would be helpful to have driver logging while attempting to add codes.

Damn, didn’t do any logging since some Ikea blind problems, and just remembered I would have to be on the same LAN as the hub, so can’t do it now :frowning:

1 Like

Which model hub do you have?

1 Like

Hub v2 and the model number on the Z-Wave module in the Kwikset 912 lock is 450241.

1 Like

Just to add to my frustration now these locks also most of the time don’t update status if you use the keypad to lock/unlock them :frowning:
Reported to ST but not holding my breath since even problems with CT100 thermostat reported months ago are not fixed!

@JohnRichard JohnRichard

John, can you please confirm that these locks still work for you?
I got another and both have the same problem.

Yes, I have one and it’s been very responsive to Pressing Lock/Unlock in the SmartThings App, Automations, and programming Guest Codes, as well as Turning the Lock Manually or Pressing Codes on the Keypad.

1 Like

I’m shocked ! …and jealous :slight_smile:
Makes me wonder what is the difference.
Tried both the default ST handler, and installing edge driver, no difference :frowning:
FW 4.10

Data * MSR: 0090-0003-0336

  • fw: 4.10
  • networkSecurityLevel: ZWAVE_S0_LEGACY


I checked the old/GroovyIDE but it’s blank because I’m using @philh30’s Edge Driver.

I also checked the API Browser+ but I’m not seeing it in Details or Status

I’m happy to check if you let me know where you’re pulling that info from.

Also: How many of these locks do you have? If you have multiple, I think you need to remove them ALL properly from your Z-Wave network, assure Philh30’s Edge Drivers are installed, then Add them back in. Otherwise, they might be picking up the Old/IDE Drivers.