Kwikset 910 Lock Not Showing Correct Lock Status in ST App or Alexa

I have a Kwikset 910 Smartcode lock which has worked well with ST and then Alexa. The lock status in both apps was always current within a few seconds of it changing either via routine or manual operation. Recently the lock status in BOTH ST and Alexa apps doesn’t update. If it is unlocked and I go into ST and Alexa apps it will show locked UNTIL I go to ST app and touch the “LOCKED” button and then it changes to “UNLOCKED” . If I then go back into Alexa app it shows correctly as unlocked. Any way to correct this status problem? Thanks

Try to exclude and pair your lock again, sometimes it loses directional communication (i.e. updates only flow in one direction). Also try adding a buffering device near your lock and it may help reduce communication issues:

Thanks. Being somewhat unfamiliar with terms, exclude the device means to remove it fro ST app and repair. In IDE my route is directly from device to hub. I have no repeaters and can’t easily move the hub further from lock.

Hey there! @ocalamike, I just wanted to provide you with this troubleshooting article for excluding devices in the Smart Things application to assist you with doing so.

Here is the link to the troubleshooting article on how to exclude devices: Manage Z-Wave Utilities with the SmartThings Hub

I hope this message finds you well!


Thanks. I’ll take a look. Much appreciated.

1 Like

You should consider adding one, even if you can’t move the hub as it provides the buffering the lock needs to have a reliable mesh experience.

OK. I’ll take a look at repeaters. I guess I thought the zigbee and z wave devices I had served as repeaters but I’m still pretty ignorant about this stuff.

Battery operated - no
Main powered Z-Wave Plus - yes

RBoy, I saw a post about this " A “future proof” Universal Enhanced Z-Wave Lock device handler". Should I change my Kwikset 910 device handler to this one? Would that possibly help?

That DTH has a lot of fixes and enhanced features which can be used by your Kwikset lock but the symptoms you describe above specifically point to a lack of buffering in your mesh and the DTH alone may not resolve it.

OK. It is just odd that I had no issues with this lock showing lock status promptly in ST and Alexa app until recently. I went ahead and changed out the lock batteries but that made no difference. Also rebooted hub and router with no improvement and did z wave repair from ST app. The only thing I haven’t tried yet is excluding lock and adding it back. I’ll try that next and if that doesn’t help I’ll get a repeater.