Kwikset 888 app lock status

Hey guys, Im brand new to ST and home automation so this is my first post. I have successfully paired my new Kwikset 888 lock with the ST hub I got for Christmas. And I am running the updated app. The app shows an incorrect lock status. When I manually unlock the deadbolt and the app reads “unlocked” and hit the lock button in the app, it locks the deadbolt but the status automatically switches back to unlocked even though it locked the lock. So I hit the button again and the app attempts to lock the deadbolt even though its locked. I paired the lock using the app because the Kwikset 888 is compatible to ST. Any ideas on how to fix this?? I have deleted and re-paired it and ran the z-wave repair with no luck. Thanks!

Thanks for the reply. That thread seems pretty intense to me so it will take some time for me to get through being so new. After a brief skim it seems to be referencing the hub being busy ? My Kwikset lock is the only device I have paired so far. Also, my batter life is 100%.

So I switched to the classic app and can now lock and unlock the deadbolt but the status remains unlocked.

Its Z-Wave also.

How far apart is the lock from the hub?

Its approximately 15 ft away from the hub. Could it be the distance to the hub even though the lock and unlock functions are working?

Ok, that should be fine. It’s almost like the device didn’t join properly. I’d try removing the lock from ST and rejoin it right next to the hub, and then move it back to the door.

I will give it a try and report back. Thank you

1 Like

So I found the solution to my problem via an ST FB group… the deadbolt throw into my door jamb isn’t long enough. It was suggested that I try it with the door open and that worked. ST was able to indicate if the door was locked or not. I just have to make the throw longer. Easy fix!

1 Like

Wow, never thought of throw being an issue. Great find!

I have it figured out!!! I am new at this too Shaun and I had the same problem. My Kwikset 888 lock that was paired with my Vivint Home Security System was being added successfully to Smartthings after being unpaired from Vivint and factory reset. It would connect to Smartthings, but then nothing but checking status and wouldn’t work. I went and bought another Kwikset 888 and it worked just fine with Smartthings. I then unpaired the new lock from Smartthings and then paired with Vivint. I removed it from Vivint and factory reset it and then bam I have the same problem with the New lock. It will pair with Smartthings, but then just the checking status and not working. So I got to thinking and I determined that the problem was that the anti theft feature had been enabled on the lock when paired with Vivint so I repaired the lock with Vivint and it didn’t pair correctly, so I removed it again and then re-paired it again to Vivint. This time I selected to keep the anti theft feature disabled. I removed it from Vivint and then paired it successfully with Smartthings and it’s fully functional. I then did the same thing with the original lock and I now have two Kwikset locks paired with Smartthings that are fully functional. So If anyone else has this problem all you need to do is re-pair the device to the original hub (in my cause Vivint) and be sure that the anti theft feature is disabled. Then it can be unpaired and paired with any compatible hub. I’m a newbie at this to, but pretty tech savy.