Kwikset locks now pairing after reset ST

Hi All,

I have two kwikset (910) lock that I had connected/paired with ST (Hub V3), but I had to reset ST and could not remove the locks before now I can’t connect/pair these locks again.

I have tried to reset the locks (using the program button procedure and also the lock button procedure) but I don’t work.

Another help I need from you guys is that one of the locks I could connect but it did not work (lock/unlock) and I could not get any status from the lock, even it could connect/pair with ST - before the issue above) easily. I can operate it locally using my code on the lock, I’ve tried pairing sitting the lock besides the Hub

Any help ?

Perform a general device exclusion on the locks. Then try to add.

If you have any custom device handlers installed, login to IDE and republish them. Then perform exclude and try to add.

Run z-wave repair if devices connect but can not perform actions through app.

1 Like

@jkp, thanks.
I could pair both locks, but the problem persist with one of the locks.

Even though it shows it is paired it does not show any information (battery, status) and don’t let me lock/unlock it from the APP, I have tried several times using different approaches.

I am trying to avoid replace the lock or to buy a new z wave board if possible.

One test that I did not do yet is to swap both z wave boards from one lock with other and see if it works, but I am not sure it can/will cause issues to the one that is working.

Any other suggestion ?

You might try adding a z-wave repeater between the hub and the lock


To @jkp point see this topic on why a repeater is required even if it’s close to the hub or the other lock is working without one.

1 Like

Thank you @jkp and @RBoy I will add a repeater and will update this topic soon.


Hi, I’ve added a Monoprice 27481 to my z wave network but my lock still does not work.
I’ve called smartthings support they said my lock is blocked by a Vivint, so I have to call Kwikset for a replacement, I’ve called Kwikset and was told they cannot replace as I am not the one that bought this and they also told me to call Vivint and ask them to remove their software from the lock, I then called Vivint and, as I am not a Vivint customer, theis suggestion is to buy a new lock :disappointed:

Do you guys have any suggestion ?

My other question is, how can I ensure the Monoprice 27481 is acting as a repeater ? I have different sensors (works with Smartthings) they loose connection with my hub quite ofter (once or twice a day) these sensors are Visonic MCT-340 E door/window sensors

Thank you