Kwikset 910 Door lock not responding

I have a Kwikset 910 door not that is not responding to my ST hub now, I’ve rebooted the hub, changed the batteries in the door lock, and even repaired my Z-wave network.

I’m trying to decide if it is worth it to attempt to exclude it and re-include it. Or is it possible the Z-wave radio when out on the lock? The lock and codes are working fine, I’ve submitted a ticket to ST but haven’t heard anything yet.

Anyone have any ideas? It had been working perfectly, and I used it in my dashboard and ST app and now just reports unlocked all of the time.

Have you moved/replaced any other zwave devices? You need beaming support in the repeater just before the lock, and not all zwave repeaters support beaming.

I haven’t moved or replaced any other Z-wave devices. I have 2 Z-wave switches about 3 feet from the door lock. How can I tell if my repeaters support beaming?

Check each device’s conformance statement on the zwave alliance site:

@JDRoberts Yeah, it looks like they support beaming.

Hard to tell, then, hopefully support can help.

Would you mind telling me how this turned out? I have the same problem with a 910. It worked for a while and then stopped responding. I’ve replaced batteries and even moved my hub a few feet from the lock. Mine reports locked all of the time.

Some level of diagnostics from the hub and what it sees with each device would be nice.

Did you do a zwave repair after you moved the hub? Just physically moving a device doesn’t change the routing path, you need to update the address tables after all the devices are in place.

Live logging in the IDE can show you quite a bit. Contact support through the Chat window on the troubleshooting page (support link at the top right of this page) or by email and they should be able to help.

I did do a repair. I’ve also noticed that the red led on the Kwikset (the one under the cover) flashes each time I send a command. That tells me that it is seeing my hub with no problems. It just isn’t responding to my hub. I also moved my wifi to a different channel. So far nothing has helped.

I’m wondering if I should remove and re-pair it to the hub?

Is it a zwave or a zigbee lock? WiFi can interfere with zigbee, but doesn’t affect zwave.

Again, I would talk to support. They can look at your individual setup and see what’s going on in more detail.

@tangential Did you reset the lock w/ taking out the batteries and holding down the lock key as you place the batteries back in?

I’ve had my lose its connect a few times when it gets jammed, and I have to do this. It is a Zwave lock. A few times I’ve had to reset the lock like 3 or 4 times, and reboot my hub and it will finally start working again.

I haven’t had to remove and re-pair my lock since i got about 16 months ago.

1 Like

I finally got it working again. I excluded it, deleted it, reset it (a few times) and it is now pair and behaving properly.

I noticed as part of this process that I never could really tell where on the 2.4 gHz spectrum the hub is at. I arbitrarily moved my OpenMesh access points to a different channel but I don’t think that had anything to do with finally getting it working again.

If you’re talking about zigbee, if you check the IDE (developers link in the top right of this page), the hub profile will tell you what zigbee channel your hub uses.

Zwave operates at 908.42 MHz in the US, there’s no overlap with the 2.4 band.

The SmartThings gen 1 hub has both a zigbee and a zwave antenna.

Thanks for the info. I’ll move my mesh network back to channel 11 then.

I think I’ve discovered that all of my problems were caused by operator error. I was using the Z-wave lock code developed by Erik Thayer (and it is a nice app with this 910 lock) and apparently the last time I pasted in a code update I ended up with 2 copies of the code. Somehow it saved and loaded but I think that is when my lock problems started. After I finally got the lock working again I went in to put the latest copy of his code in place and discovered the error.

With that error corrected everything is working just right; even notifications which didn’t work before.

1 Like

Hello John Harlow. Can you please guide me through the process you used to get Kwikset 910 works with smartthings. I have the same issue. I have tried to excluded it, deleted it, and reset it but nothing works. Thank you.